aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-geometry/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/octave-forge-geometry/Makefile')
-rw-r--r--math/octave-forge-geometry/Makefile19
1 files changed, 4 insertions, 15 deletions
diff --git a/math/octave-forge-geometry/Makefile b/math/octave-forge-geometry/Makefile
index 3294c70737c3..33b22bd46f25 100644
--- a/math/octave-forge-geometry/Makefile
+++ b/math/octave-forge-geometry/Makefile
@@ -10,22 +10,11 @@ COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
WWW= https://packages.octave.org/
LICENSE= GPLv3
-LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
+LICENSE_FILE= ${WRKDIR}/${OCTAVE_SRC}/COPYING
-USES= python:env
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR} \
+ ${OCTAVE_TARBALLS_DIR}/matgeom.tar.gz:math/octave-forge-matgeom
-# OCTSRC is the name of the directory of the package.
-# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
-OCTSRC= ${DISTNAME}
-
-WRKSRC= ${WRKDIR}/${OCTSRC}/src
-
-RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}lxml>=0:devel/py-lxml@${PY_FLAVOR}
-RUN_DEPENDS+= ${TARBALLS_DIR}/matgeom.tar.gz:math/octave-forge-matgeom
-
-.include "${.CURDIR}/../../Mk/bsd.octave.mk"
-
-post-build:
- cd ${WRKDIR} && ${TAR} cfz ${OCTAVE_DISTNAME}.tar.gz ${OCTSRC}
+USES= octave python:env
.include <bsd.port.mk>