aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-ncarray/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/octave-forge-ncarray/Makefile')
-rw-r--r--math/octave-forge-ncarray/Makefile22
1 files changed, 5 insertions, 17 deletions
diff --git a/math/octave-forge-ncarray/Makefile b/math/octave-forge-ncarray/Makefile
index fbcb48d63641..89c9d1036249 100644
--- a/math/octave-forge-ncarray/Makefile
+++ b/math/octave-forge-ncarray/Makefile
@@ -9,26 +9,14 @@ COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
WWW= https://packages.octave.org/
LICENSE= GPLv2
-LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
+LICENSE_FILE= ${WRKDIR}/${OCTAVE_SRC}/COPYING
-# OCTSRC is the name of the directory of the package.
-# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
-OCTSRC= ${DISTNAME}
+RUN_DEPENDS= ${OCTAVE_TARBALLS_DIR}/netcdf.tar.gz:math/octave-forge-netcdf \
+ ${OCTAVE_TARBALLS_DIR}/statistics.tar.gz:math/octave-forge-statistics
-WRKSRC= ${WRKDIR}/${OCTSRC}/src
-
-RUN_DEPENDS+= ${TARBALLS_DIR}/netcdf.tar.gz:math/octave-forge-netcdf
-RUN_DEPENDS+= ${TARBALLS_DIR}/statistics.tar.gz:math/octave-forge-statistics
-
-.include "${.CURDIR}/../../Mk/bsd.octave.mk"
-
-do-build:
- @${DO_NADA}
+USES= octave
NO_ARCH= yes
-
-post-build:
- ${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
- cd ${WRKDIR} && ${TAR} cfz ${OCTAVE_DISTNAME}.tar.gz ${OCTSRC}
+NO_BUILD= yes
.include <bsd.port.mk>