aboutsummaryrefslogtreecommitdiff
path: root/math/octave-forge-sole/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/octave-forge-sole/Makefile')
-rw-r--r--math/octave-forge-sole/Makefile18
1 files changed, 5 insertions, 13 deletions
diff --git a/math/octave-forge-sole/Makefile b/math/octave-forge-sole/Makefile
index cef579cf3108..7ff5393b555c 100644
--- a/math/octave-forge-sole/Makefile
+++ b/math/octave-forge-sole/Makefile
@@ -10,23 +10,15 @@ COMMENT= Octave-forge package ${OCTAVE_PKGNAME}
WWW= https://packages.octave.org/
LICENSE= GPLv3
-LICENSE_FILE= ${WRKDIR}/${OCTSRC}/COPYING
+LICENSE_FILE= ${WRKDIR}/${OCTAVE_SRC}/COPYING
-# OCTSRC is the name of the directory of the package.
-# It is usually ${OCTAVE_PKGNAME} or ${DISTNAME}.
-OCTSRC= ${OCTAVE_PKGNAME}
+RUN_DEPENDS= ${OCTAVE_TARBALLS_DIR}/bim.tar.gz:math/octave-forge-bim
-RUN_DEPENDS+= ${TARBALLS_DIR}/bim.tar.gz:math/octave-forge-bim
+USES= octave
-.include "${.CURDIR}/../../Mk/bsd.octave.mk"
-
-do-build:
- @${DO_NADA}
+OCTAVE_SRC= ${OCTAVE_PKGNAME}
NO_ARCH= yes
-
-post-build:
- ${RM} ${WRKSRC}/Makefile ${WRKSRC}/configure
- cd ${WRKDIR} && ${TAR} cfz ${OCTAVE_DISTNAME}.tar.gz ${OCTSRC}
+NO_BUILD= yes
.include <bsd.port.mk>