aboutsummaryrefslogtreecommitdiff
path: root/math/suitesparse-klu
diff options
context:
space:
mode:
Diffstat (limited to 'math/suitesparse-klu')
-rw-r--r--math/suitesparse-klu/Makefile18
-rw-r--r--math/suitesparse-klu/files/patch-KLU_Demo_Makefile18
-rw-r--r--math/suitesparse-klu/pkg-descr2
-rw-r--r--math/suitesparse-klu/pkg-plist20
4 files changed, 30 insertions, 28 deletions
diff --git a/math/suitesparse-klu/Makefile b/math/suitesparse-klu/Makefile
index bf8aa4b2306f..0961f556daac 100644
--- a/math/suitesparse-klu/Makefile
+++ b/math/suitesparse-klu/Makefile
@@ -1,15 +1,13 @@
-# Created by: Thierry Thomas (<thierry@pompo.net>)
-
PORTNAME= ${MPORTNAME:tl}
-PORTVERSION= 1.3.9
+PORTVERSION= 2.3.2
CATEGORIES= math
COMMENT= Sparse LU factorization, for circuit simulation
+WWW= https://faculty.cse.tamu.edu/davis/suitesparse.html
LICENSE= LGPL21+
-LIB_DEPENDS= libmetis.so:math/metis \
- libamd.so:math/suitesparse-amd \
+LIB_DEPENDS= libamd.so:math/suitesparse-amd \
libbtf.so:math/suitesparse-btf \
libcamd.so:math/suitesparse-camd \
libcolamd.so:math/suitesparse-colamd \
@@ -17,10 +15,18 @@ LIB_DEPENDS= libmetis.so:math/metis \
libcholmod.so:math/suitesparse-cholmod
USES= localbase:ldflags
-OMP_NEEDED= yes
+CMAKE_ARGS+= -DNSTATIC:BOOL=off
MPORTNAME= KLU
USE_LDCONFIG= yes
.include "${.CURDIR}/../../math/suitesparse/bsd.suitesparse.mk"
+
+post-stage-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/README.txt \
+ ${STAGEDIR}${DOCSDIR}/${MPORTNAME}_README.txt
+ ${INSTALL_DATA} ${BUILD_WRKSRC}/Doc/${MPORTNAME}_UserGuide.pdf \
+ ${STAGEDIR}${DOCSDIR}
+
.include <bsd.port.post.mk>
diff --git a/math/suitesparse-klu/files/patch-KLU_Demo_Makefile b/math/suitesparse-klu/files/patch-KLU_Demo_Makefile
deleted file mode 100644
index a8e5fa35797b..000000000000
--- a/math/suitesparse-klu/files/patch-KLU_Demo_Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
---- KLU/Demo/Makefile.orig 2021-05-17 01:04:52 UTC
-+++ KLU/Demo/Makefile
-@@ -32,15 +32,7 @@ all: library klu_simple kludemo kluldemo
- - ./kluldemo < ../Matrix/ctina.mtx
-
- library:
-- ( cd ../../SuiteSparse_config ; $(MAKE) )
- ( cd ../Lib ; $(MAKE) )
-- ( cd ../../BTF ; $(MAKE) library )
-- ( cd ../../AMD ; $(MAKE) library )
-- ( cd ../../COLAMD ; $(MAKE) library )
-- ( cd ../../CHOLMOD ; $(MAKE) library )
-- - ( cd ../../CAMD ; $(MAKE) )
-- - ( cd ../../CCOLAMD ; $(MAKE) )
-- - ( cd ../.. ; $(MAKE) metis )
-
- purge: distclean
-
diff --git a/math/suitesparse-klu/pkg-descr b/math/suitesparse-klu/pkg-descr
index cfd39e997b15..6ae58d46f0e6 100644
--- a/math/suitesparse-klu/pkg-descr
+++ b/math/suitesparse-klu/pkg-descr
@@ -6,5 +6,3 @@ applications. It relies on a permutation to block triangular form (BTF), several
methods for finding a fill-reducing ordering (variants of approximate minimum
degree, and nested dissection), and a sparse left-looking LU factorization
method to factorize each block.
-
-WWW: http://faculty.cse.tamu.edu/davis/suitesparse.html
diff --git a/math/suitesparse-klu/pkg-plist b/math/suitesparse-klu/pkg-plist
index be3e628039a5..3ec8e46b6ff6 100644
--- a/math/suitesparse-klu/pkg-plist
+++ b/math/suitesparse-klu/pkg-plist
@@ -1,6 +1,22 @@
include/suitesparse/klu.h
+include/suitesparse/klu_cholmod.h
+lib/cmake/KLU/KLUConfig.cmake
+lib/cmake/KLU/KLUConfigVersion.cmake
+lib/cmake/KLU/KLUTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/KLU/KLUTargets.cmake
+lib/cmake/KLU_CHOLMOD/KLU_CHOLMODConfig.cmake
+lib/cmake/KLU_CHOLMOD/KLU_CHOLMODConfigVersion.cmake
+lib/cmake/KLU_CHOLMOD/KLU_CHOLMODTargets-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/KLU_CHOLMOD/KLU_CHOLMODTargets.cmake
+lib/libklu.a
lib/libklu.so
-lib/libklu.so.1
-lib/libklu.so.1.3.8
+lib/libklu.so.2
+lib/libklu.so.%%VER%%
+lib/libklu_cholmod.a
+lib/libklu_cholmod.so
+lib/libklu_cholmod.so.2
+lib/libklu_cholmod.so.%%VER%%
+libdata/pkgconfig/KLU.pc
+libdata/pkgconfig/KLU_CHOLMOD.pc
%%PORTDOCS%%%%DOCSDIR%%/KLU_README.txt
%%PORTDOCS%%%%DOCSDIR%%/KLU_UserGuide.pdf