aboutsummaryrefslogtreecommitdiff
path: root/math/suitesparse-slip_lu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'math/suitesparse-slip_lu/Makefile')
-rw-r--r--math/suitesparse-slip_lu/Makefile25
1 files changed, 25 insertions, 0 deletions
diff --git a/math/suitesparse-slip_lu/Makefile b/math/suitesparse-slip_lu/Makefile
new file mode 100644
index 000000000000..ca39f6955bd9
--- /dev/null
+++ b/math/suitesparse-slip_lu/Makefile
@@ -0,0 +1,25 @@
+# Created by: Thierry Thomas (<thierry@pompo.net>)
+
+PORTNAME= SLIP_LU
+PORTVERSION= 1.0.2
+CATEGORIES= math
+
+COMMENT= Sparse Left-looking Integer-Preserving LU Factorization
+
+LICENSE= GPLv2+ LGPL3+
+LICENSE_COMB= dual
+LICENSE_FILE= ${BUILD_WRKSRC}/License/license.txt
+
+LIB_DEPENDS= libgmp.so:math/gmp \
+ libmpfr.so:math/mpfr \
+ libamd.so:math/suitesparse-amd \
+ libcolamd.so:math/suitesparse-colamd
+
+USES= localbase:ldflags
+OMP_NEEDED= yes
+
+BUILD_WRKSRC= ${WRKSRC}/${PORTNAME}
+USE_LDCONFIG= yes
+
+.include "${.CURDIR}/../../math/suitesparse/bsd.suitesparse.mk"
+.include <bsd.port.post.mk>