aboutsummaryrefslogtreecommitdiff
path: root/multimedia/vdr-plugin-markad/files/patch-plugin-Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'multimedia/vdr-plugin-markad/files/patch-plugin-Makefile')
-rw-r--r--multimedia/vdr-plugin-markad/files/patch-plugin-Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/multimedia/vdr-plugin-markad/files/patch-plugin-Makefile b/multimedia/vdr-plugin-markad/files/patch-plugin-Makefile
index 15ca635394a9..948b589939c7 100644
--- a/multimedia/vdr-plugin-markad/files/patch-plugin-Makefile
+++ b/multimedia/vdr-plugin-markad/files/patch-plugin-Makefile
@@ -1,17 +1,21 @@
--- a/plugin/Makefile
+++ b/plugin/Makefile
-@@ -100,10 +100,15 @@ i18n: $(I18Nmsgs) $(I18Npot)
+@@ -99,11 +99,19 @@ i18n: $(I18Nmsgs) $(I18Npot)
### Targets:
- install:
+ install: all
++ifdef FREEBSD
+ ${INSTALL_PROGRAM} $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION) $(PREFIX)/lib/vdr/libvdr-$(PLUGIN).so.$(APIVERSION)
++else
+ cp --remove-destination libvdr-$(PLUGIN).so $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION)
++endif
libvdr-$(PLUGIN).so: $(OBJS)
$(CXX) $(CXXFLAGS) -shared $(OBJS) $(LIBS) -o $@
+ifdef FREEBSD
-+ @cp -f $@ $(LIBDIR)/$@.$(APIVERSION)
++ cp -f libvdr-$(PLUGIN).so $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION)
+else
- @cp --remove-destination $@ $(LIBDIR)/$@.$(APIVERSION)
+ cp --remove-destination libvdr-$(PLUGIN).so $(LIBDIR)/libvdr-$(PLUGIN).so.$(APIVERSION)
+endif
clean: