aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/driftnet/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/driftnet/Makefile')
-rw-r--r--net-mgmt/driftnet/Makefile21
1 files changed, 12 insertions, 9 deletions
diff --git a/net-mgmt/driftnet/Makefile b/net-mgmt/driftnet/Makefile
index 136059b9ee5e..621408e59b13 100644
--- a/net-mgmt/driftnet/Makefile
+++ b/net-mgmt/driftnet/Makefile
@@ -1,7 +1,7 @@
# Created by: Simon 'corecode' Schubert <corecode@corecode.ath.cx>
PORTNAME= driftnet
-PORTVERSION= 1.3.0
+PORTVERSION= 1.4.0
DISTVERSIONPREFIX= v
CATEGORIES= net-mgmt
@@ -11,27 +11,30 @@ COMMENT= Tool to grab images out of (your) TCP connections
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libgif.so:graphics/giflib \
- libpng.so:graphics/png
BUILD_DEPENDS= makedepend:devel/makedepend
+LIB_DEPENDS= libgif.so:graphics/giflib \
+ libpng.so:graphics/png \
+ libwebp.so:graphics/webp \
+ libwebsockets.so:net/libwebsockets
-GNU_CONFIGURE= yes
USES= autoreconf gettext-runtime gmake gnome jpeg localbase:ldflags \
pkgconfig xorg
USE_CSTD= c99
USE_GITHUB= yes
+GH_ACCOUNT= deiv
USE_GNOME= gtk20
USE_XORG= x11 xext xi
-GH_ACCOUNT= deiv
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --disable-debug
-CONFIGURE_ARGS+= --disable-http-display
+INSTALL_TARGET= install-strip
-PLIST_FILES= bin/driftnet man/man1/driftnet.1.gz
+PLIST_FILES= ${DATADIR}/static-html/index.html \
+ bin/driftnet \
+ man/man1/driftnet.1.gz
PORTDOCS= *
-INSTALL_TARGET= install-strip
-
OPTIONS_DEFINE= DOCS
.include <bsd.port.mk>