aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt/icinga2/files/patch-components__CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt/icinga2/files/patch-components__CMakeLists.txt')
-rw-r--r--net-mgmt/icinga2/files/patch-components__CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/net-mgmt/icinga2/files/patch-components__CMakeLists.txt b/net-mgmt/icinga2/files/patch-components__CMakeLists.txt
new file mode 100644
index 000000000000..248fe4b11458
--- /dev/null
+++ b/net-mgmt/icinga2/files/patch-components__CMakeLists.txt
@@ -0,0 +1,19 @@
+--- components/CMakeLists.txt.orig 2014-06-16 23:20:12.000000000 +0000
++++ components/CMakeLists.txt 2014-06-16 23:20:18.000000000 +0000
+@@ -1,7 +1,14 @@
+ add_subdirectory(checker)
+ add_subdirectory(compat)
+-add_subdirectory(db_ido_mysql)
+-add_subdirectory(db_ido_pgsql)
++
++if(WITH_MYSQL)
++ add_subdirectory(db_ido_mysql)
++endif()
++
++if(WITH_PGSQL)
++ add_subdirectory(db_ido_pgsql)
++endif()
++
+ add_subdirectory(demo)
+ add_subdirectory(livestatus)
+ add_subdirectory(notification)