aboutsummaryrefslogtreecommitdiff
path: root/net-mgmt
diff options
context:
space:
mode:
Diffstat (limited to 'net-mgmt')
-rw-r--r--net-mgmt/p5-Mon/Makefile8
-rw-r--r--net-mgmt/p5-Mon/pkg-descr3
-rw-r--r--net-mgmt/p5-Net-IPv4Addr/Makefile8
-rw-r--r--net-mgmt/p5-Net-Netmask/Makefile5
-rw-r--r--net-mgmt/p5-Net-SNMP/Makefile1
-rw-r--r--net-mgmt/p5-Net-SNMP3/Makefile1
-rw-r--r--net-mgmt/p5-NetAddr-IP/Makefile7
-rw-r--r--net-mgmt/p5-SNMP-Util/Makefile7
-rw-r--r--net-mgmt/p5-SNMP/Makefile1
-rw-r--r--net-mgmt/p5-SNMP_Session/Makefile1
10 files changed, 11 insertions, 31 deletions
diff --git a/net-mgmt/p5-Mon/Makefile b/net-mgmt/p5-Mon/Makefile
index 2c7d5e121b58..596306bb1380 100644
--- a/net-mgmt/p5-Mon/Makefile
+++ b/net-mgmt/p5-Mon/Makefile
@@ -15,15 +15,11 @@ DISTNAME= Mon-${PORTVERSION}
MAINTAINER= nick@netdot.net
-USE_PERL5= YES
+PERL_CONFIGURE= YES
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Mon::SNMP.3 \
Mon::Client.3 \
Mon::Protocol.3
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-
-do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
-
.include <bsd.port.mk>
diff --git a/net-mgmt/p5-Mon/pkg-descr b/net-mgmt/p5-Mon/pkg-descr
index 5d6b8678a322..a97b1716a277 100644
--- a/net-mgmt/p5-Mon/pkg-descr
+++ b/net-mgmt/p5-Mon/pkg-descr
@@ -4,4 +4,5 @@ things like special logging routines and persistent monitors are being
considered.
"mon" is a tool for monitoring the availability of services.
-More information can be found at http://www.kernel.org/software/mon/.
+
+WWW: http://www.kernel.org/software/mon/.
diff --git a/net-mgmt/p5-Net-IPv4Addr/Makefile b/net-mgmt/p5-Net-IPv4Addr/Makefile
index 51b18c597dc7..ef34bababbe4 100644
--- a/net-mgmt/p5-Net-IPv4Addr/Makefile
+++ b/net-mgmt/p5-Net-IPv4Addr/Makefile
@@ -14,14 +14,10 @@ PKGNAMEPREFIX= p5-
MAINTAINER= bradh@uunet.co.za
-USE_PERL5= yes
+PERL_CONFIGURE= yes
+
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN1= ipv4calc.1
MAN3= Net::IPv4Addr.3
-do-configure:
-
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
- PREFIX=${PREFIX}
-
.include <bsd.port.mk>
diff --git a/net-mgmt/p5-Net-Netmask/Makefile b/net-mgmt/p5-Net-Netmask/Makefile
index 20028a3bf3ff..5cd8d012e6ab 100644
--- a/net-mgmt/p5-Net-Netmask/Makefile
+++ b/net-mgmt/p5-Net-Netmask/Makefile
@@ -14,12 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= wchao@isi.edu
-USE_PERL5= yes
+PERL_CONFIGURE= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Net::Netmask.3
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
-
.include <bsd.port.mk>
diff --git a/net-mgmt/p5-Net-SNMP/Makefile b/net-mgmt/p5-Net-SNMP/Makefile
index 0b7393700223..974a033225ac 100644
--- a/net-mgmt/p5-Net-SNMP/Makefile
+++ b/net-mgmt/p5-Net-SNMP/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= ports@FreeBSD.org
WRKSRC= ${WRKDIR}/${PORTNAME}-3.6
-USE_PERL5= yes
PERL_CONFIGURE= yes
MAN3= Net::SNMP.3
diff --git a/net-mgmt/p5-Net-SNMP3/Makefile b/net-mgmt/p5-Net-SNMP3/Makefile
index 0b7393700223..974a033225ac 100644
--- a/net-mgmt/p5-Net-SNMP3/Makefile
+++ b/net-mgmt/p5-Net-SNMP3/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= ports@FreeBSD.org
WRKSRC= ${WRKDIR}/${PORTNAME}-3.6
-USE_PERL5= yes
PERL_CONFIGURE= yes
MAN3= Net::SNMP.3
diff --git a/net-mgmt/p5-NetAddr-IP/Makefile b/net-mgmt/p5-NetAddr-IP/Makefile
index 54ae0256110d..d9090c307854 100644
--- a/net-mgmt/p5-NetAddr-IP/Makefile
+++ b/net-mgmt/p5-NetAddr-IP/Makefile
@@ -14,12 +14,9 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@freebsd.org
-USE_PERL5= yes
+PERL_CONFIGURE= yes
+
MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= NetAddr::IP.3
-do-configure:
- @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
- PREFIX=${PREFIX}
-
.include <bsd.port.mk>
diff --git a/net-mgmt/p5-SNMP-Util/Makefile b/net-mgmt/p5-SNMP-Util/Makefile
index e1566db80e67..558fcdc7262d 100644
--- a/net-mgmt/p5-SNMP-Util/Makefile
+++ b/net-mgmt/p5-SNMP-Util/Makefile
@@ -14,14 +14,11 @@ PKGNAMEPREFIX= p5-
MAINTAINER= fenner@FreeBSD.org
-RUN_DEPENDS= ${PREFIX}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/SNMP.pm:${PORTSDIR}/net/p5-SNMP
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/SNMP.pm:${PORTSDIR}/net/p5-SNMP
-USE_PERL5= yes
+PERL_CONFIGURE= yes
MAN3= SNMP::Util.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-do-configure:
- @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
-
.include <bsd.port.mk>
diff --git a/net-mgmt/p5-SNMP/Makefile b/net-mgmt/p5-SNMP/Makefile
index 6c8dbc430d20..b20696c57b45 100644
--- a/net-mgmt/p5-SNMP/Makefile
+++ b/net-mgmt/p5-SNMP/Makefile
@@ -16,7 +16,6 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= snmp.4:${PORTSDIR}/net/net-snmp
-USE_PERL5= yes
PERL_CONFIGURE= yes
post-install:
diff --git a/net-mgmt/p5-SNMP_Session/Makefile b/net-mgmt/p5-SNMP_Session/Makefile
index 846aa5a7ce07..18467d482485 100644
--- a/net-mgmt/p5-SNMP_Session/Makefile
+++ b/net-mgmt/p5-SNMP_Session/Makefile
@@ -13,7 +13,6 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
-USE_PERL5= yes
PERL_CONFIGURE= yes
pre-install: