aboutsummaryrefslogtreecommitdiff
path: root/net-p2p/ethash/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/ethash/Makefile')
-rw-r--r--net-p2p/ethash/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/net-p2p/ethash/Makefile b/net-p2p/ethash/Makefile
new file mode 100644
index 000000000000..6eacfae84d55
--- /dev/null
+++ b/net-p2p/ethash/Makefile
@@ -0,0 +1,22 @@
+PORTNAME= ethash
+PORTVERSION= 0.8.0
+DISTVERSIONPREFIX= v
+CATEGORIES= net-p2p
+
+MAINTAINER= nc@FreeBSD.org
+COMMENT= C/C++ implementation of Ethash and ProgPoW
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libbenchmark.so:devel/benchmark \
+ libgtest.so:devel/googletest
+
+USES= cmake
+USE_GITHUB= yes
+GH_ACCOUNT= chfast
+
+CMAKE_OFF= HUNTER_ENABLED
+
+.include <bsd.port.mk>
+