aboutsummaryrefslogtreecommitdiff
path: root/net/asterisk11
diff options
context:
space:
mode:
Diffstat (limited to 'net/asterisk11')
-rw-r--r--net/asterisk11/Makefile9
-rw-r--r--net/asterisk11/distinfo4
-rw-r--r--net/asterisk11/files/patch-main__asterisk.exports.in12
-rw-r--r--net/asterisk11/files/patch-main__http.c11
4 files changed, 24 insertions, 12 deletions
diff --git a/net/asterisk11/Makefile b/net/asterisk11/Makefile
index 9723d1ae1eff..08ccb79e5598 100644
--- a/net/asterisk11/Makefile
+++ b/net/asterisk11/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= asterisk
-PORTVERSION= 11.5.1
+PORTVERSION= 11.7.0
CATEGORIES= net
MASTER_SITES= http://downloads.asterisk.org/pub/telephony/asterisk/ \
http://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
@@ -25,9 +25,8 @@ LDFLAGS+= -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/openh323
CFLAGS+= -I${LOCALBASE}/include
USE_CSTD= gnu89
-USE_GMAKE= yes
USE_GNOME= libxml2
-USES= bison
+USES= bison gmake
USE_RC_SUBR= asterisk
MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}" \
@@ -38,7 +37,9 @@ MAKE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
NOISY_BUILD=YES \
DOCSDIR=${DOCSDIR} \
ASTCFLAGS="${CFLAGS}"
-MAN8= asterisk.8 astgenkey.8 autosupport.8 safe_asterisk.8
+MAN8= asterisk.8 astgenkey.8 autosupport.8 safe_asterisk.8 astdb2bdb.8 \
+ astdb2sqlite3.8
+
CONFLICTS_BUILD= linuxthreads-*
CONFLICTS_INSTALL= asterisk*-1.4* asterisk*-1.6* asterisk*-1.8*
diff --git a/net/asterisk11/distinfo b/net/asterisk11/distinfo
index 939f32e738ac..0a94c78ea452 100644
--- a/net/asterisk11/distinfo
+++ b/net/asterisk11/distinfo
@@ -1,2 +1,2 @@
-SHA256 (asterisk-11.5.1.tar.gz) = fefa9def9c8f97c89931f12b29b3ac616ae1a8454c01c524678163061dcb42b2
-SIZE (asterisk-11.5.1.tar.gz) = 30580447
+SHA256 (asterisk-11.7.0.tar.gz) = 4fb283b96447f5d871632a14069f35643c8c34d08d6ec5fedf0ae3df30e0c397
+SIZE (asterisk-11.7.0.tar.gz) = 34779538
diff --git a/net/asterisk11/files/patch-main__asterisk.exports.in b/net/asterisk11/files/patch-main__asterisk.exports.in
index 438dd1034eca..185c0c8f1e6c 100644
--- a/net/asterisk11/files/patch-main__asterisk.exports.in
+++ b/net/asterisk11/files/patch-main__asterisk.exports.in
@@ -1,9 +1,9 @@
---- main/asterisk.exports.in.orig 2012-04-10 21:44:03.532803004 +0200
-+++ main/asterisk.exports.in 2012-04-10 21:44:41.134621539 +0200
-@@ -44,6 +44,8 @@
- LINKER_SYMBOL_PREFIXres_srtp;
- LINKER_SYMBOL_PREFIXres_srtp_policy;
- LINKER_SYMBOL_PREFIXsecure_call_info;
+--- main/asterisk.exports.in.orig 2013-08-22 10:22:39.000000000 +0200
++++ main/asterisk.exports.in 2013-10-27 13:38:56.825678450 +0100
+@@ -65,6 +65,8 @@
+
+ */
+ LINKER_SYMBOL_PREFIX_IO_stdin_used;
+ LINKER_SYMBOL_PREFIX__progname;
+ LINKER_SYMBOL_PREFIXenviron;
local:
diff --git a/net/asterisk11/files/patch-main__http.c b/net/asterisk11/files/patch-main__http.c
new file mode 100644
index 000000000000..f82a52bb8470
--- /dev/null
+++ b/net/asterisk11/files/patch-main__http.c
@@ -0,0 +1,11 @@
+--- main/http.c.orig 2013-12-17 23:42:58.982720307 +0100
++++ main/http.c 2013-12-17 23:43:16.054863909 +0100
+@@ -1024,7 +1024,7 @@
+ struct http_uri_redirect *redirect;
+ struct ast_flags config_flags = { reload ? CONFIG_FLAG_FILEUNCHANGED : 0 };
+ uint32_t bindport = DEFAULT_PORT;
+- RAII_VAR(struct ast_sockaddr *, addrs, NULL, ast_free);
++ struct ast_sockaddr *addrs = NULL;
+ int num_addrs = 0;
+ int http_tls_was_enabled = 0;
+