aboutsummaryrefslogtreecommitdiff
path: root/net/fb303/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/fb303/Makefile')
-rw-r--r--net/fb303/Makefile13
1 files changed, 9 insertions, 4 deletions
diff --git a/net/fb303/Makefile b/net/fb303/Makefile
index 34ccc3056ef6..95ee3ca53f7d 100644
--- a/net/fb303/Makefile
+++ b/net/fb303/Makefile
@@ -1,15 +1,17 @@
PORTNAME= fb303
-DISTVERSION= g20210709
-PORTREVISION= 1
+DISTVERSIONPREFIX= v
+DISTVERSION= 2024.03.25.00
CATEGORIES= net
MAINTAINER= yuri@FreeBSD.org
COMMENT= Base Thrift service and a common set of functionality
+WWW= https://github.com/facebook/fb303
LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libboost_regex.so:devel/boost-libs \
+ libbzip2.so:misc/vxl \
libdouble-conversion.so:devel/double-conversion \
libevent.so:devel/libevent \
libfizz.so:security/fizz \
@@ -17,7 +19,9 @@ LIB_DEPENDS= libboost_regex.so:devel/boost-libs \
libfolly.so:devel/folly \
libgflags.so:devel/gflags \
libglog.so:devel/glog \
+ libicuuc.so:devel/icu \
liblz4.so:archivers/liblz4 \
+ libmvfst_server.so:net/mvfst \
libsnappy.so:archivers/snappy \
libsodium.so:security/libsodium \
libthriftcpp2.so:devel/fbthrift \
@@ -30,14 +34,15 @@ USE_LDCONFIG= yes
USE_GITHUB= yes
GH_ACCOUNT= facebook
-GH_TAGNAME= 83ae662219660d30b49ad8474f5c63bbfc6d5f6f
CXXFLAGS+= -fPIC
+CXXFLAGS+= -DGLOG_USE_GLOG_EXPORT
CMAKE_ON= BUILD_SHARED_LIBS
CMAKE_OFF= PYTHON_EXTENSIONS
post-install:
- @${RMDIR} ${STAGEDIR}${PREFIX}/include/fb303/test
+ @${RMDIR} \
+ ${STAGEDIR}${PREFIX}/include/fb303/test
.include <bsd.port.mk>