aboutsummaryrefslogtreecommitdiff
path: root/net/go-tcping/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/go-tcping/Makefile')
-rw-r--r--net/go-tcping/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/net/go-tcping/Makefile b/net/go-tcping/Makefile
new file mode 100644
index 000000000000..152229a467b5
--- /dev/null
+++ b/net/go-tcping/Makefile
@@ -0,0 +1,30 @@
+PORTNAME= tcping
+DISTVERSIONPREFIX= v
+DISTVERSION= 2.5.0
+PORTREVISION= 3
+CATEGORIES= net
+MASTER_SITES= https://raw.githubusercontent.com/${GH_ACCOUNT}/${PORTNAME}/${DISTVERSIONFULL}/:gomod
+PKGNAMEPREFIX= go-
+DISTFILES= go.mod:gomod
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Command-line utility to ping TCP ports written in Go
+WWW= https://github.com/pouriyajamshidi/tcping
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go:modules
+
+USE_GITHUB= yes
+GH_ACCOUNT= pouriyajamshidi
+
+GO_MODULE= github.com/${GH_ACCOUNT}/${PORTNAME}
+
+PLIST_FILES= bin/gotcping
+
+post-install:
+ @${MV} ${STAGEDIR}${PREFIX}/bin/${PORTNAME} \
+ ${STAGEDIR}${PREFIX}/bin/gotcping
+
+.include <bsd.port.mk>