aboutsummaryrefslogtreecommitdiff
path: root/net/haproxy20/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/haproxy20/Makefile')
-rw-r--r--net/haproxy20/Makefile17
1 files changed, 11 insertions, 6 deletions
diff --git a/net/haproxy20/Makefile b/net/haproxy20/Makefile
index 52d777683d83..ec0f1d942999 100644
--- a/net/haproxy20/Makefile
+++ b/net/haproxy20/Makefile
@@ -1,18 +1,23 @@
-# Created by: Hugo Saro <hugo@barafranca.com>
-
PORTNAME= haproxy
-DISTVERSION= 2.0.25
+DISTVERSION= 2.0.33
+PORTREVISION= 1
CATEGORIES= net www
PKGNAMESUFFIX= 20
MASTER_SITES= http://www.haproxy.org/download/2.0/src/
MAINTAINER= demon@FreeBSD.org
COMMENT= Reliable, high performance TCP/HTTP load balancer
+WWW= https://www.haproxy.org
LICENSE= GPLv2 LGPL21
LICENSE_COMB= multi
-CONFLICTS_INSTALL= haproxy-[0-9]* haproxy-devel-[0-9]* haproxy17-[0-9]* haproxy18-[0-9]* haproxy19-[0-9]* haproxy21-[0-9]*
+DEPRECATED= Upstream EOL reaches on 2024-06-30
+EXPIRATION_DATE= 2024-06-30
+BROKEN_FreeBSD_14= process runaway
+BROKEN_FreeBSD_15= process runaway
+
+CONFLICTS_INSTALL= haproxy haproxy-devel haproxy17 haproxy18
USES= compiler:c++11-lang cpe gmake
USE_RC_SUBR= haproxy
@@ -28,7 +33,7 @@ DPCRE_DESC= Link dynamically
SPCRE_DESC= Link statically
DEVICEATLAS_DESC= DeviceAtlas Device Detection support
PROMEX_DESC= Enable Prometheus exporter
-OPTIONS_DEFAULT= SPCRE OPENSSL
+OPTIONS_DEFAULT= SPCRE OPENSSL PROMEX
DPCRE_LIB_DEPENDS= libpcre.so:devel/pcre
DPCRE_MAKE_ARGS= USE_PCRE=1 USE_PCRE_JIT=1
@@ -54,7 +59,7 @@ post-build:
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/haproxy ${STAGEDIR}${PREFIX}/sbin/
${INSTALL_PROGRAM} ${WRKSRC}/contrib/halog/halog ${STAGEDIR}${PREFIX}/sbin/
- ${INSTALL_MAN} ${WRKSRC}/doc/haproxy.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/doc/haproxy.1 ${STAGEDIR}${PREFIX}/share/man/man1
${MKDIR} ${STAGEDIR}${DOCSDIR}
(cd ${WRKSRC}/doc/ && ${COPYTREE_SHARE} \* ${STAGEDIR}${DOCSDIR})
${MKDIR} ${STAGEDIR}${EXAMPLESDIR}