aboutsummaryrefslogtreecommitdiff
path: root/net/iwnet/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/iwnet/Makefile')
-rw-r--r--net/iwnet/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/net/iwnet/Makefile b/net/iwnet/Makefile
new file mode 100644
index 000000000000..b6298dd324f8
--- /dev/null
+++ b/net/iwnet/Makefile
@@ -0,0 +1,27 @@
+PORTNAME= iwnet
+PORTVERSION= g20220907
+CATEGORIES= net www
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Asynchronous HTTP library with websockets, SSL, routing
+WWW= https://github.com/Softmotions/iwnet
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+BUILD_DEPENDS= ${LOCALBASE}/include/iowow/iowow.h:databases/iowow
+
+USES= cmake compiler:c11
+USE_GITHUB= yes
+GH_ACCOUNT= Softmotions
+GH_TAGNAME= b67e4ba
+USE_LDCONFIG= yes
+
+CMAKE_ARGS= -DBUILD_SHARED_LIBS:BOOL=ON -DBUILD_TESTS:BOOL=ON
+
+OPTIONS_DEFINE= DOCS
+
+do-test:
+ @cd ${TEST_WRKSRC} && ctest -C ${CMAKE_BUILD_TYPE} ${_MAKE_JOBS}
+
+.include <bsd.port.mk>