aboutsummaryrefslogtreecommitdiff
path: root/net/libngtcp2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/libngtcp2/Makefile')
-rw-r--r--net/libngtcp2/Makefile17
1 files changed, 6 insertions, 11 deletions
diff --git a/net/libngtcp2/Makefile b/net/libngtcp2/Makefile
index be18bb452d00..215e17283363 100644
--- a/net/libngtcp2/Makefile
+++ b/net/libngtcp2/Makefile
@@ -1,28 +1,23 @@
-# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
-
PORTNAME= ngtcp2
-PORTVERSION= 0.1.0.g20210831
+PORTVERSION= 1.3.0
CATEGORIES= net
+MASTER_SITES= https://github.com/ngtcp2/ngtcp2/releases/download/v${PORTVERSION}/
PKGNAMEPREFIX= lib
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Implementation of QUIC protocol
+WWW= https://nghttp2.org/ngtcp2/ \
+ https://github.com/ngtcp2/ngtcp2
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= autoreconf compiler:c++17-lang libtool pathfix pkgconfig
+USES= compiler:c++14-lang libtool pathfix pkgconfig tar:xz
CONFIGURE_ARGS= --enable-lib-only --with-jemalloc
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USE_CXXSTD= c++17
+USE_CXXSTD= c++14
USE_LDCONFIG= yes
-GH_TAGNAME= fce1b7f
-USE_GITHUB= yes
-
-post-patch:
- @${REINPLACE_CMD} -e 's|%%PORTVERSION%%|${PORTVERSION}|' ${WRKSRC}/configure.ac
-
.include <bsd.port.mk>