aboutsummaryrefslogtreecommitdiff
path: root/net/liferea/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/liferea/Makefile')
-rw-r--r--net/liferea/Makefile18
1 files changed, 16 insertions, 2 deletions
diff --git a/net/liferea/Makefile b/net/liferea/Makefile
index fb2be7777ea7..834a04deb1d2 100644
--- a/net/liferea/Makefile
+++ b/net/liferea/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= liferea
-PORTVERSION= 0.4.7b
-PORTREVISION= 1
+PORTVERSION= 0.4.7c
CATEGORIES= net gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= liferea
@@ -15,6 +14,11 @@ MASTER_SITE_SUBDIR= liferea
MAINTAINER= perky@FreeBSD.org
COMMENT= Simple RSS/RDF feed reader
+.ifdef WITH_MOZILLA
+BUILD_DEPENDS= mozilla:${PORTSDIR}/www/mozilla
+RUN_DEPENDS= mozilla:${PORTSDIR}/www/mozilla
+.endif
+
USE_X_PREFIX= yes
USE_GNOME= gnomeprefix gnomehack gconf2 libxml2 libgtkhtml \
gnomevfs2
@@ -23,9 +27,19 @@ USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+.ifdef WITH_MOZILLA
+PLIST_SUB= MOZ=""
+.else
+PLIST_SUB= MOZ="@comment "
+.endif
post-patch:
+.ifdef WITH_MOZILLA
${REINPLACE_CMD} -e 's,/usr/lib/moz,${X11BASE}/lib/moz,g' \
${WRKSRC}/src/liferea
+.else
+ ${REINPLACE_CMD} -e 's,gtkmozembed,donttrythis,g' \
+ ${WRKSRC}/configure
+.endif
.include <bsd.port.mk>