aboutsummaryrefslogtreecommitdiff
path: root/net/netatalk3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/netatalk3/Makefile')
-rw-r--r--net/netatalk3/Makefile16
1 files changed, 8 insertions, 8 deletions
diff --git a/net/netatalk3/Makefile b/net/netatalk3/Makefile
index f378560cea6f..6c8c38771d02 100644
--- a/net/netatalk3/Makefile
+++ b/net/netatalk3/Makefile
@@ -1,23 +1,23 @@
-# Created by: stb
-
PORTNAME= netatalk
-PORTVERSION= 3.1.12
-PORTREVISION= 4
+PORTVERSION= 3.1.18
+PORTREVISION= 3
PORTEPOCH= 1
CATEGORIES= net
-MASTER_SITES= SF
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME}-${PORTVERSION:S/./-/g}
PKGNAMESUFFIX= 3
MAINTAINER= marcus@FreeBSD.org
COMMENT= File server for Mac OS X
+WWW= http://netatalk.sourceforge.net/
LICENSE= GPLv2
LIB_DEPENDS= libgcrypt.so:security/libgcrypt \
libevent.so:devel/libevent
-USES= bdb:5+ cpe gettext gmake iconv libtool perl5 pkgconfig shebangfix ssl tar:bzip2
+USES= bdb:18 cpe gettext gmake iconv libtool perl5 pkgconfig shebangfix ssl tar:bzip2
GNU_CONFIGURE= yes
+GNU_CONFIGURE_MANPREFIX= ${PREFIX}/share
USE_LDCONFIG= yes
USE_RC_SUBR= netatalk
INSTALL_TARGET=install-strip
@@ -59,7 +59,7 @@ MDNSRESPONDER_LIB_DEPENDS= libdns_sd.so:net/mDNSResponder
MDNSRESPONDER_SUB_LIST= ZEROCONF="mdnsd"
LDAP_CONFIGURE_ON= --with-ldap=${LOCALBASE}
LDAP_CFLAGS= -I${LOCALBASE}/include -L${LOCALBASE}/lib
-LDAP_USE= OPENLDAP=yes
+LDAP_USES= ldap
LDAP_CONFIGURE_OFF= --without-ldap
SENDFILE_CONFIGURE_ENABLE=sendfile
DBUS_USES= gnome python
@@ -75,7 +75,7 @@ LIBWRAP_CONFIGURE_ENABLE=tcp-wrappers
SHEBANG_GLOB= afpstats
-CONFLICTS= bigloo-2.* cap-6.0.* tct-1.* netatalk-[12]* yudit-[0-9]*
+CONFLICTS= jday yudit # bin/dbd man/man1/uniconv.1.gz
.include <bsd.port.pre.mk>