aboutsummaryrefslogtreecommitdiff
path: root/net/radiator/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/radiator/Makefile')
-rw-r--r--net/radiator/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/net/radiator/Makefile b/net/radiator/Makefile
index ce9017b1afdd..c783c5eb3bb3 100644
--- a/net/radiator/Makefile
+++ b/net/radiator/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Radiator
-PORTVERSION= 3.11
+PORTVERSION= 3.16
CATEGORIES= net
MASTER_SITES= # fetch manually
EXTRACT_SUFX= .tgz
@@ -15,6 +15,8 @@ DIST_SUBDIR= ${PORTNAME}
MAINTAINER= shanali@yahoo.com
COMMENT= Radiator Radius Server by Open System Consultants
+OPTIONS= MYSQL "MySQL Support" off
+
BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -34,6 +36,10 @@ IGNORE= will not be automatically fetched due to licensing\
same directory as well)
.endif
+.if defined(WITH_MYSQL)
+RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/mysql.pm:${PORTSDIR}/databases/p5-DBD-mysql
+.endif
+
pre-configure:
.if exists(${DISTDIR}/${DIST_SUBDIR}/patches-${PORTVERSION}.tar.gz)
${TAR} -xvzf ${DISTDIR}/${DIST_SUBDIR}/patches-${PORTVERSION}.tar.gz -C ${WRKSRC}