aboutsummaryrefslogtreecommitdiff
path: root/net/rsync
diff options
context:
space:
mode:
Diffstat (limited to 'net/rsync')
-rw-r--r--net/rsync/Makefile1
-rw-r--r--net/rsync/files/patch-utils.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/net/rsync/Makefile b/net/rsync/Makefile
index 272a1457c60e..9c0c5dc97ef7 100644
--- a/net/rsync/Makefile
+++ b/net/rsync/Makefile
@@ -7,6 +7,7 @@
PORTNAME= rsync
PORTVERSION= 3.0.2
+PORTREVISION= 1
CATEGORIES= net ipv6
MASTER_SITES= http://rsync.samba.org/ftp/%SUBDIR%/ \
ftp://ftp.samba.org/pub/%SUBDIR%/ \
diff --git a/net/rsync/files/patch-utils.c b/net/rsync/files/patch-utils.c
new file mode 100644
index 000000000000..1a998a268cc4
--- /dev/null
+++ b/net/rsync/files/patch-utils.c
@@ -0,0 +1,11 @@
+--- util.c.orig 2008-05-30 20:02:16.000000000 +0400
++++ util.c 2008-05-30 20:04:01.000000000 +0400
+@@ -582,7 +582,7 @@
+ } else
+ use_buf = glob.arg_buf;
+
+- if (from_glob || arg) {
++ if (from_glob || (arg && len)) {
+ STRUCT_STAT st;
+ int is_dir;
+