aboutsummaryrefslogtreecommitdiff
path: root/net/rubygem-gitlab-omniauth-openid-connect/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'net/rubygem-gitlab-omniauth-openid-connect/Makefile')
-rw-r--r--net/rubygem-gitlab-omniauth-openid-connect/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/net/rubygem-gitlab-omniauth-openid-connect/Makefile b/net/rubygem-gitlab-omniauth-openid-connect/Makefile
new file mode 100644
index 000000000000..90bc712c993e
--- /dev/null
+++ b/net/rubygem-gitlab-omniauth-openid-connect/Makefile
@@ -0,0 +1,23 @@
+# Created by: Matthias Fechner <mfechner@FreeBSD.org>
+
+PORTNAME= gitlab-omniauth-openid-connect
+PORTVERSION= 0.4.0
+CATEGORIES= net rubygems
+MASTER_SITES= RG
+
+MAINTAINER= mfechner@FreeBSD.org
+COMMENT= OpenID Connect Strategy for OmniAuth
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= rubygem-addressable>=2.7<3.0:www/rubygem-addressable \
+ rubygem-omniauth>=1.9<2.0:security/rubygem-omniauth \
+ rubygem-openid_connect>=1.2<2.0:net/rubygem-openid_connect
+
+USES= gem
+USE_RUBY= yes
+
+NO_ARCH= yes
+
+.include <bsd.port.mk>