aboutsummaryrefslogtreecommitdiff
path: root/net/zerotier/files
diff options
context:
space:
mode:
Diffstat (limited to 'net/zerotier/files')
-rw-r--r--net/zerotier/files/patch-make-bsd.mk11
-rw-r--r--net/zerotier/files/patch-node_Packet.cpp11
-rw-r--r--net/zerotier/files/zerotier.in2
3 files changed, 23 insertions, 1 deletions
diff --git a/net/zerotier/files/patch-make-bsd.mk b/net/zerotier/files/patch-make-bsd.mk
new file mode 100644
index 000000000000..c7ef859cbe74
--- /dev/null
+++ b/net/zerotier/files/patch-make-bsd.mk
@@ -0,0 +1,11 @@
+--- make-bsd.mk.orig 2018-05-18 08:50:17 UTC
++++ make-bsd.mk
+@@ -159,7 +159,7 @@ clean:
+ rm -rf *.a *.o node/*.o controller/*.o osdep/*.o service/*.o ext/http-parser/*.o build-* zerotier-one zerotier-idtool zerotier-selftest zerotier-cli $(ONE_OBJS) $(CORE_OBJS)
+
+ debug: FORCE
+- gmake -j 4 ZT_DEBUG=1
++ $(MAKE) -j ZT_DEBUG=1
+
+ install: one
+ rm -f /usr/local/sbin/zerotier-one
diff --git a/net/zerotier/files/patch-node_Packet.cpp b/net/zerotier/files/patch-node_Packet.cpp
new file mode 100644
index 000000000000..7bb792ce3e63
--- /dev/null
+++ b/net/zerotier/files/patch-node_Packet.cpp
@@ -0,0 +1,11 @@
+--- node/Packet.cpp.orig 2018-05-18 09:03:14 UTC
++++ node/Packet.cpp
+@@ -332,7 +332,7 @@ static const int LZ4_minLength = (MFLIMIT+1);
+
+ #define LZ4_STATIC_ASSERT(c) { enum { LZ4_static_assert = 1/(int)(!!(c)) }; } /* use only *after* variable declarations */
+
+-static inline unsigned LZ4_NbCommonBytes (register reg_t val)
++static inline unsigned LZ4_NbCommonBytes (reg_t val)
+ {
+ if (LZ4_isLittleEndian()) {
+ if (sizeof(val)==8) {
diff --git a/net/zerotier/files/zerotier.in b/net/zerotier/files/zerotier.in
index 95b19fe2cac3..62880d21dd58 100644
--- a/net/zerotier/files/zerotier.in
+++ b/net/zerotier/files/zerotier.in
@@ -4,7 +4,7 @@
#
# PROVIDE: zerotier
# REQUIRE: FILESYSTEMS netif
-# BEFORE: pf ipfw
+# BEFORE: pf ipfw ipfilter
# KEYWORD: shutdown
#
# Add these lines to /etc/rc.conf.local or /etc/rc.conf