aboutsummaryrefslogtreecommitdiff
path: root/net
diff options
context:
space:
mode:
Diffstat (limited to 'net')
-rw-r--r--net/zerotier/Makefile7
-rw-r--r--net/zerotier/distinfo6
-rw-r--r--net/zerotier/files/patch-make-bsd.mk11
-rw-r--r--net/zerotier/files/patch-node_Packet.cpp11
-rw-r--r--net/zerotier/files/zerotier.in2
5 files changed, 31 insertions, 6 deletions
diff --git a/net/zerotier/Makefile b/net/zerotier/Makefile
index 870e763c16af..f2a982dea996 100644
--- a/net/zerotier/Makefile
+++ b/net/zerotier/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= zerotier
-PORTVERSION= 1.2.4
-PORTREVISION= 2
+DISTVERSION= 1.2.8
CATEGORIES= net
MAINTAINER= dch@FreeBSD.org
@@ -24,6 +23,10 @@ GH_PROJECT= ZeroTierOne
CFLAGS+= -flax-vector-conversions
+OPTIONS_DEFINE= DBG
+DBG_DESC= Enable foreground debugging for zerotier-one daemon
+DBG_ALL_TARGET= debug
+
PLIST_FILES= bin/zerotier-cli bin/zerotier-idtool sbin/zerotier-one
do-install:
diff --git a/net/zerotier/distinfo b/net/zerotier/distinfo
index 889818a97717..344194a8ce41 100644
--- a/net/zerotier/distinfo
+++ b/net/zerotier/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1493361909
-SHA256 (zerotier-ZeroTierOne-1.2.4_GH0.tar.gz) = 9f275b3732b721f02cc4b8df75b51e6a8fb56dfe1a542a7bd681538d852b0358
-SIZE (zerotier-ZeroTierOne-1.2.4_GH0.tar.gz) = 7963254
+TIMESTAMP = 1525679369
+SHA256 (zerotier-ZeroTierOne-1.2.8_GH0.tar.gz) = 08e2df34550d6bb68e106eaac48babb481160046818b0944ec41f1e158548a47
+SIZE (zerotier-ZeroTierOne-1.2.8_GH0.tar.gz) = 6009764
diff --git a/net/zerotier/files/patch-make-bsd.mk b/net/zerotier/files/patch-make-bsd.mk
new file mode 100644
index 000000000000..c7ef859cbe74
--- /dev/null
+++ b/net/zerotier/files/patch-make-bsd.mk
@@ -0,0 +1,11 @@
+--- make-bsd.mk.orig 2018-05-18 08:50:17 UTC
++++ make-bsd.mk
+@@ -159,7 +159,7 @@ clean:
+ rm -rf *.a *.o node/*.o controller/*.o osdep/*.o service/*.o ext/http-parser/*.o build-* zerotier-one zerotier-idtool zerotier-selftest zerotier-cli $(ONE_OBJS) $(CORE_OBJS)
+
+ debug: FORCE
+- gmake -j 4 ZT_DEBUG=1
++ $(MAKE) -j ZT_DEBUG=1
+
+ install: one
+ rm -f /usr/local/sbin/zerotier-one
diff --git a/net/zerotier/files/patch-node_Packet.cpp b/net/zerotier/files/patch-node_Packet.cpp
new file mode 100644
index 000000000000..7bb792ce3e63
--- /dev/null
+++ b/net/zerotier/files/patch-node_Packet.cpp
@@ -0,0 +1,11 @@
+--- node/Packet.cpp.orig 2018-05-18 09:03:14 UTC
++++ node/Packet.cpp
+@@ -332,7 +332,7 @@ static const int LZ4_minLength = (MFLIMIT+1);
+
+ #define LZ4_STATIC_ASSERT(c) { enum { LZ4_static_assert = 1/(int)(!!(c)) }; } /* use only *after* variable declarations */
+
+-static inline unsigned LZ4_NbCommonBytes (register reg_t val)
++static inline unsigned LZ4_NbCommonBytes (reg_t val)
+ {
+ if (LZ4_isLittleEndian()) {
+ if (sizeof(val)==8) {
diff --git a/net/zerotier/files/zerotier.in b/net/zerotier/files/zerotier.in
index 95b19fe2cac3..62880d21dd58 100644
--- a/net/zerotier/files/zerotier.in
+++ b/net/zerotier/files/zerotier.in
@@ -4,7 +4,7 @@
#
# PROVIDE: zerotier
# REQUIRE: FILESYSTEMS netif
-# BEFORE: pf ipfw
+# BEFORE: pf ipfw ipfilter
# KEYWORD: shutdown
#
# Add these lines to /etc/rc.conf.local or /etc/rc.conf