aboutsummaryrefslogtreecommitdiff
path: root/science
diff options
context:
space:
mode:
Diffstat (limited to 'science')
-rw-r--r--science/step/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/science/step/Makefile b/science/step/Makefile
index ee86b37c62c2..f79cc9c77c43 100644
--- a/science/step/Makefile
+++ b/science/step/Makefile
@@ -11,7 +11,8 @@ LIB_DEPENDS= libcln.so:math/cln \
libgsl.so:math/gsl \
libqalculate.so:math/libqalculate
-USES= cmake:outsource eigen:3 gettext kde:5 pkgconfig qt:5 tar:xz
+USES= cmake:outsource compiler:c++11-lang eigen:3 gettext kde:5 \
+ pkgconfig qt:5 tar:xz
USE_KDE= attica auth bookmarks codecs completion config configwidgets \
coreaddons crash doctools ecm emoticons guiaddons i18n \
iconthemes init itemmodels itemviews jobwidgets js \
@@ -21,6 +22,10 @@ USE_KDE= attica auth bookmarks codecs completion config configwidgets \
USE_QT= core dbus gui network opengl printsupport qml quick svg \
widgets xml \
buildtools_build qmake_build
+CXXFLAGS_powerpc64= -Wno-error=return-type
+CXXFLAGS_powerpc= -Wno-error=return-type
+CXXFLAGS_powerpcspe= -Wno-error=return-type
+CXXFLAGS_sparc64= -Wno-error=return-type
OPTIONS_DEFINE= DOCS