aboutsummaryrefslogtreecommitdiff
path: root/security/cryptopp/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/cryptopp/Makefile')
-rw-r--r--security/cryptopp/Makefile22
1 files changed, 3 insertions, 19 deletions
diff --git a/security/cryptopp/Makefile b/security/cryptopp/Makefile
index 193bc797cf85..f9fa20a3d824 100644
--- a/security/cryptopp/Makefile
+++ b/security/cryptopp/Makefile
@@ -1,5 +1,5 @@
PORTNAME= cryptopp
-PORTVERSION= 8.6.0
+PORTVERSION= 8.7.0
CATEGORIES= security
MASTER_SITES= http://www.cryptopp.com/
DISTNAME= cryptopp${PORTVERSION:S/.//g}
@@ -55,24 +55,8 @@ TOOLS_TEST_TARGET_OFF= test
.include <bsd.port.options.mk>
-.if ${PORT_OPTIONS:MSIMD}
-. if ${ARCH} == i386 || ${ARCH} == amd64
-. if !${MACHINE_CPU:Msse2}
-CXXFLAGS+= -DCRYPTOPP_DISABLE_ASM -DCRYPTOPP_DISABLE_SSE2
-. endif
-. if !${MACHINE_CPU:Mssse3}
-CXXFLAGS+= -DCRYPTOPP_DISABLE_SSSE3
-. endif
-. if !${MACHINE_CPU:Msse41}
-CXXFLAGS+= -DCRYPTOPP_DISABLE_SSE4
-. endif
-. elif ${ARCH} == powerpc || ${ARCH:Mpowerpc64*}
-CXXFLAGS+= -DCRYPTOPP_ALTIVEC_AVAILABLE
-. endif
-.else
-CXXFLAGS+= -DCRYPTOPP_DISABLE_ASM -DCRYPTOPP_DISABLE_SSE2 \
- -DCRYPTOPP_DISABLE_SSSE3 -DCRYPTOPP_DISABLE_SSE4 \
- -DCRYPTOPP_DISABLE_ALTIVEC
+.if !${PORT_OPTIONS:MSIMD}
+CXXFLAGS+= -DCRYPTOPP_DISABLE_ASM
.endif
pre-configure-FULL_DEBUG-on: