aboutsummaryrefslogtreecommitdiff
path: root/security/gnome-keyring/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/gnome-keyring/Makefile')
-rw-r--r--security/gnome-keyring/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/security/gnome-keyring/Makefile b/security/gnome-keyring/Makefile
index 4a53e28ad760..3114d6299050 100644
--- a/security/gnome-keyring/Makefile
+++ b/security/gnome-keyring/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gnome-keyring
-PORTVERSION= 3.16.0
+PORTVERSION= 3.18.3
CATEGORIES= security gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -19,12 +19,13 @@ LIB_DEPENDS= libgnome-keyring.so:${PORTSDIR}/security/libgnome-keyring \
libtasn1.so:${PORTSDIR}/security/libtasn1 \
libp11-kit.so:${PORTSDIR}/security/p11-kit \
libgcrypt.so:${PORTSDIR}/security/libgcrypt
-RUN_DEPENDS= ca_root_nss>=0:${PORTSDIR}/security/ca_root_nss
+RUN_DEPENDS= ca_root_nss>=0:${PORTSDIR}/security/ca_root_nss \
+ pinentry-gnome3:${PORTSDIR}/security/pinentry-gnome3
PORTSCOUT= limitw:1,even
USE_GNOME= gtk30 intlhack libxslt:build
-USES= compiler:c11 cpe gettext gmake libtool pathfix \
+USES= compiler:c11 cpe gettext gmake gnome libtool pathfix \
pkgconfig tar:xz
CPE_VENDOR= gnome
INSTALLS_ICONS= yes
@@ -36,4 +37,6 @@ LIBS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
GLIB_SCHEMAS= org.gnome.crypto.cache.gschema.xml
+SUB_FILES= pkg-message
+
.include <bsd.port.mk>