aboutsummaryrefslogtreecommitdiff
path: root/security/py-m2crypto/files
diff options
context:
space:
mode:
Diffstat (limited to 'security/py-m2crypto/files')
-rw-r--r--security/py-m2crypto/files/patch-SWIG::Makefile21
-rw-r--r--security/py-m2crypto/files/patch-SWIG::_m2crypto.i11
-rw-r--r--security/py-m2crypto/files/patch-setup.py59
3 files changed, 82 insertions, 9 deletions
diff --git a/security/py-m2crypto/files/patch-SWIG::Makefile b/security/py-m2crypto/files/patch-SWIG::Makefile
index a51b1c11d3ab..5c316a783da3 100644
--- a/security/py-m2crypto/files/patch-SWIG::Makefile
+++ b/security/py-m2crypto/files/patch-SWIG::Makefile
@@ -1,12 +1,15 @@
---- Makefile.orig Wed Aug 6 17:33:10 2003
-+++ Makefile Wed Aug 6 17:34:04 2003
-@@ -3,8 +3,7 @@
- CFLAGS = -DTHREADING -g
- INCLUDE = -I/usr/local/include -I.
- LIBS = -L/usr/local/lib -lssl -lcrypto
--PYVER = 2.2
+--- SWIG/Makefile.orig Mon Sep 15 13:34:31 2003
++++ SWIG/Makefile Fri Mar 18 20:32:40 2005
+@@ -8,9 +8,9 @@
+ #else
+ PYVER = 2.3
+ #endif
-PYINCLUDE = -DHAVE_CONFIG_H -I/usr/local/include/python$(PYVER) \
+- -I/usr/local/lib/python$(PYVER)/config
+-PYLIB = /usr/local/lib/python$(PYVER)/config
+PYINCLUDE = -DHAVE_CONFIG_H -I%%PYTHON_INCLUDEDIR%% \
- -I/usr/local/lib/python$(PYVER)/config
- PYLIB = /usr/local/lib/python$(PYVER)/config
++ -I%%PYTHON_INCLUDEDIR%%/config
++PYLIB = %%PYTHON_INCLUDEDIR%%/config
+
+ all: _m2crypto
diff --git a/security/py-m2crypto/files/patch-SWIG::_m2crypto.i b/security/py-m2crypto/files/patch-SWIG::_m2crypto.i
new file mode 100644
index 000000000000..084483eefe80
--- /dev/null
+++ b/security/py-m2crypto/files/patch-SWIG::_m2crypto.i
@@ -0,0 +1,11 @@
+--- SWIG/_m2crypto.i.orig Sun Oct 26 11:19:08 2003
++++ SWIG/_m2crypto.i Fri Mar 18 22:45:07 2005
+@@ -31,7 +31,7 @@
+ %include _dsa.i
+ %include _ssl.i
+ %include _x509.i
+-%include _asn1.i
++//%include _asn1.i
+ %include _pkcs7.i
+ %include _util.i
+
diff --git a/security/py-m2crypto/files/patch-setup.py b/security/py-m2crypto/files/patch-setup.py
new file mode 100644
index 000000000000..3848aa024d10
--- /dev/null
+++ b/security/py-m2crypto/files/patch-setup.py
@@ -0,0 +1,59 @@
+--- setup.py.orig Sun Mar 28 08:06:59 2004
++++ setup.py Fri Mar 18 22:44:10 2005
+@@ -12,56 +12,6 @@
+ from distutils.core import setup, Extension
+ from distutils.command import build_ext
+
+-# This copy of swig_sources is from Python 2.2.
+-
+-def swig_sources (self, sources):
+-
+- """Walk the list of source files in 'sources', looking for SWIG
+- interface (.i) files. Run SWIG on all that are found, and
+- return a modified 'sources' list with SWIG source files replaced
+- by the generated C (or C++) files.
+- """
+-
+- new_sources = []
+- swig_sources = []
+- swig_targets = {}
+-
+- # XXX this drops generated C/C++ files into the source tree, which
+- # is fine for developers who want to distribute the generated
+- # source -- but there should be an option to put SWIG output in
+- # the temp dir.
+-
+- if self.swig_cpp:
+- target_ext = '.cpp'
+- else:
+- target_ext = '.c'
+-
+- for source in sources:
+- (base, ext) = os.path.splitext(source)
+- if ext == ".i": # SWIG interface file
+- new_sources.append(base + target_ext)
+- swig_sources.append(source)
+- swig_targets[source] = new_sources[-1]
+- else:
+- new_sources.append(source)
+-
+- if not swig_sources:
+- return new_sources
+-
+- swig = self.find_swig()
+- swig_cmd = [swig, "-python", "-ISWIG"]
+- if self.swig_cpp:
+- swig_cmd.append("-c++")
+-
+- for source in swig_sources:
+- target = swig_targets[source]
+- self.announce("swigging %s to %s" % (source, target))
+- self.spawn(swig_cmd + ["-o", target, source])
+-
+- return new_sources
+-
+-build_ext.build_ext.swig_sources = swig_sources
+-
+ my_inc = os.path.join(os.getcwd(), 'SWIG')
+
+ if os.name == 'nt':