aboutsummaryrefslogtreecommitdiff
path: root/security/seahorse/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'security/seahorse/Makefile')
-rw-r--r--security/seahorse/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/security/seahorse/Makefile b/security/seahorse/Makefile
index 0e98256166e6..d81d01281bf2 100644
--- a/security/seahorse/Makefile
+++ b/security/seahorse/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= seahorse
-PORTVERSION= 3.16.0
+PORTVERSION= 3.18.0
CATEGORIES= security gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -10,21 +10,20 @@ DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= GNOME application for managing encryption keys (PGP, SSH)
-BUILD_DEPENDS= gnupg>=2.1:${PORTSDIR}/security/gnupg \
+BUILD_DEPENDS= gnupg>=2.1.4:${PORTSDIR}/security/gnupg \
valac:${PORTSDIR}/lang/vala \
itstool:${PORTSDIR}/textproc/itstool
LIB_DEPENDS= libgpgme.so:${PORTSDIR}/security/gpgme \
- libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib \
libgcr-3.so:${PORTSDIR}/security/gcr \
libsecret-1.so:${PORTSDIR}/security/libsecret \
libsoup-2.4.so:${PORTSDIR}/devel/libsoup
-RUN_DEPENDS= gnupg>=2.1:${PORTSDIR}/security/gnupg
+RUN_DEPENDS= gnupg>=2.1.4:${PORTSDIR}/security/gnupg
PORTSCOUT= limitw:1,even
USE_XORG= sm
USE_LDCONFIG= yes
-USES= gettext gmake libtool pathfix pkgconfig tar:xz
+USES= gettext gmake gnome libtool pathfix pkgconfig tar:xz
USE_GNOME= intlhack gnomeprefix gtk30
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
@@ -36,12 +35,12 @@ GLIB_SCHEMAS= org.gnome.seahorse.gschema.xml \
org.gnome.seahorse.window.gschema.xml
OPTIONS_SUB= yes
-OPTIONS_DEFINE= LDAP NOTIFY AVAHI
-OPTIONS_DEFAULT=LDAP NOTIFY AVAHI
+OPTIONS_DEFINE= LDAP AVAHI
+OPTIONS_DEFAULT=LDAP AVAHI
LDAP_CONFIGURE_ENABLE= ldap
LDAP_USE= OPENLDAP=yes
-NOTIFY_CONFIGURE_ENABLE= libnotify
-NOTIFY_LIB_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify
+LDAP_DESC= LDAP keyserver support (for gpg)
+AVAHI_DESC= DNS-SD key sharing
AVAHI_CONFIGURE_ENABLE= sharing
AVAHI_LIB_DEPENDS= libavahi-client.so:${PORTSDIR}/net/avahi-app