aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/openssl/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index b75435afcf13..cfa32b67f8be 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -886,7 +886,7 @@ MLINKS+= \
.include <bsd.port.pre.mk>
-OPENSSL_BASE_SONAME!= readlink /usr/lib/libcrypto.so || true
+OPENSSL_BASE_SONAME!= readlink ${DESTDIR}/usr/lib/libcrypto.so || true
OPENSSL_SHLIBVER_BASE= ${OPENSSL_BASE_SONAME:E}
OPENSSL_BASE_SOPATH= ${OPENSSL_BASE_SONAME:H}
@@ -937,7 +937,7 @@ pre-everything::
@${FALSE}
.endif
-.if exists(/usr/lib/libcrypto.so.3) && ${OPENSSL_SHLIBVER} != 3
+.if exists(${DESTDIR}/usr/lib/libcrypto.so.3) && ${OPENSSL_SHLIBVER} != 3
pre-everything::
@${ECHO_CMD} "#"
@${ECHO_CMD} "# this ports conflicts with your base system"