aboutsummaryrefslogtreecommitdiff
path: root/security
diff options
context:
space:
mode:
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-mnemonic/Makefile20
-rw-r--r--security/py-mnemonic/distinfo3
-rw-r--r--security/py-mnemonic/pkg-descr8
4 files changed, 32 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index c88ffe8f48ca..d0a9eb08a37c 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -908,6 +908,7 @@
SUBDIR += py-mcrypt
SUBDIR += py-mhash
SUBDIR += py-mixbox
+ SUBDIR += py-mnemonic
SUBDIR += py-oauth2client
SUBDIR += py-oauthlib
SUBDIR += py-onetime
diff --git a/security/py-mnemonic/Makefile b/security/py-mnemonic/Makefile
new file mode 100644
index 000000000000..053f0e8baafa
--- /dev/null
+++ b/security/py-mnemonic/Makefile
@@ -0,0 +1,20 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= mnemonic
+PORTVERSION= 0.17
+CATEGORIES= security python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Implementation of Bitcoin BIP-0039
+
+LICENSE= MIT
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pbkdf2>=1.3:security/py-pbkdf2
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/security/py-mnemonic/distinfo b/security/py-mnemonic/distinfo
new file mode 100644
index 000000000000..4654a7936efc
--- /dev/null
+++ b/security/py-mnemonic/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1507061403
+SHA256 (mnemonic-0.17.tar.gz) = 5636ec318c2abb7d1e54b557d1822843d662008099f1588cc3ee2979c8ea06c3
+SIZE (mnemonic-0.17.tar.gz) = 21847
diff --git a/security/py-mnemonic/pkg-descr b/security/py-mnemonic/pkg-descr
new file mode 100644
index 000000000000..a4e1955f5917
--- /dev/null
+++ b/security/py-mnemonic/pkg-descr
@@ -0,0 +1,8 @@
+This BIP describes the implementation of a mnemonic code or mnemonic sentence (a
+group of easy to remember words) for the generation of deterministic wallets.
+
+It consists of two parts: generating the mnenomic, and converting it into a
+binary seed. This seed can be later used to generate deterministic wallets using
+BIP-0032 or similar methods.
+
+WWW: https://github.com/trezor/python-mnemonic