aboutsummaryrefslogtreecommitdiff
path: root/shells/mudsh/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'shells/mudsh/Makefile')
-rw-r--r--shells/mudsh/Makefile39
1 files changed, 39 insertions, 0 deletions
diff --git a/shells/mudsh/Makefile b/shells/mudsh/Makefile
new file mode 100644
index 000000000000..c17a310ccf8d
--- /dev/null
+++ b/shells/mudsh/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: mudsh
+# Date created: 28 February 2001
+# Whom: George Reid <greid@ukug.uk.freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mudsh
+PORTVERSION= 20010228
+CATEGORIES= shells
+MASTER_SITES= http://www.xirium.com/tech/mud-shell/download/
+DISTNAME= mudsh
+EXTRACT_SUFX=
+EXTRACT_ONLY=
+
+MAINTAINER= greid@ukug.uk.freebsd.org
+
+NO_WRKSUBDIR= yes
+
+NO_BUILD= yes
+
+post-extract:
+ @${CP} ${DISTDIR}/${DISTNAME} ${WRKSRC}
+
+do-patch:
+ @(${SED} -e 's,/usr/local/bin/perl,${PERL},1' ${WRKSRC}/${DISTNAME} \
+ > foo && ${MV} foo ${WRKSRC}/${DISTNAME})
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} ${PREFIX}/bin
+
+post-install:
+ @${ECHO} "updating /etc/shells"
+ @${CP} /etc/shells /etc/shells.bak
+ @(${GREP} -v ${PREFIX}/bin/mudsh /etc/shells.bak; \
+ ${ECHO} ${PREFIX}/bin/mudsh) > /etc/shells
+ @${RM} /etc/shells.bak
+
+.include <bsd.port.mk>