aboutsummaryrefslogtreecommitdiff
path: root/sysutils/gnome-control-center/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/gnome-control-center/Makefile')
-rw-r--r--sysutils/gnome-control-center/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/sysutils/gnome-control-center/Makefile b/sysutils/gnome-control-center/Makefile
index aa1ac1a9758c..f105ed56e908 100644
--- a/sysutils/gnome-control-center/Makefile
+++ b/sysutils/gnome-control-center/Makefile
@@ -1,9 +1,8 @@
# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/trunk/sysutils/gnome-control-center/Makefile 20031 2014-11-02 21:47:55Z kwm $
PORTNAME= gnome-control-center
-PORTVERSION= 3.14.4
+PORTVERSION= 3.16.3
CATEGORIES= sysutils gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome3
@@ -38,14 +37,14 @@ RUN_DEPENDS= gnome-eject:${PORTSDIR}/sysutils/gnome-mount \
gcm-calibrate:${PORTSDIR}/graphics/gnome-color-manager
CONFLICTS= gnome-media-2.[0-9]*
+PORTSCOUT= limitw:1,even
-USES= gettext gmake pathfix pkgconfig tar:xz
-USE_GNOME= gnomedesktop3 gnomemenus3 gnomeprefix intlhack libxml2
+USES= compiler:c++11-lib gettext gmake pathfix pkgconfig tar:xz
+USE_GNOME= gnomedesktop3 gnomemenus3 intltool libxml2
USE_XORG= xscrnsaver x11 xxf86misc kbproto xi
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
USE_LDCONFIG= yes
-CONFIGURE_ARGS= --with-libsocialweb=yes --disable-systemd
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
@@ -59,7 +58,8 @@ OPTIONS_DEFINE_i386= CHEESE
OPTIONS_DEFAULT_i386= CHEESE
OPTIONS_DEFINE_amd64= CHEESE
OPTIONS_DEFAULT_amd64= CHEESE
-CUPS_LIB_DEPENDS= libcups.so:${PORTSDIR}/print/cups-client
+CUPS_LIB_DEPENDS= libcups.so:${PORTSDIR}/print/cups-client \
+ libsmbclient.so:${PORTSDIR}/net/samba-libsmbclient
CUPS_CONFIGURE_ENABLE= cups
CHEESE_LIB_DEPENDS= libcheese.so:${PORTSDIR}/multimedia/cheese
CHEESE_CONFIGUE_WITH= cheese