aboutsummaryrefslogtreecommitdiff
path: root/sysutils/plasma5-kinfocenter/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/plasma5-kinfocenter/Makefile')
-rw-r--r--sysutils/plasma5-kinfocenter/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/sysutils/plasma5-kinfocenter/Makefile b/sysutils/plasma5-kinfocenter/Makefile
index 010b3c747dda..a15bd32b06f2 100644
--- a/sysutils/plasma5-kinfocenter/Makefile
+++ b/sysutils/plasma5-kinfocenter/Makefile
@@ -5,7 +5,10 @@ CATEGORIES= sysutils kde kde-plasma
MAINTAINER= kde@FreeBSD.org
COMMENT= Plasma5 utility providing system information
-LIB_DEPENDS= libpci.so:devel/libpci
+RUN_DEPENDS= lscpu:sysutils/lscpu \
+ glxinfo:graphics/mesa-demos \
+ vulkaninfo:graphics/vulkan-tools \
+ xdpyinfo:x11/xdpyinfo
USES= cmake compiler:c++11-lib gettext gl kde:5 pkgconfig qt:5 \
tar:xz xorg
@@ -26,6 +29,10 @@ USE_XORG= ice sm x11 xext
# TODO -- this should be handled correctly...
LDFLAGS+=-ldevinfo
+post-extract:
+ # File move not handled by patch
+ ${MV} ${WRKSRC}/Modules/pci/kcm_pci.json ${WRKSRC}/Modules/pci/kcm_pci.json.cmake
+
# install freebsd-logo and distrorc
post-install:
${MKDIR} ${STAGEDIR}/${DATADIR}/images