aboutsummaryrefslogtreecommitdiff
path: root/sysutils/u-boot-master/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'sysutils/u-boot-master/Makefile')
-rw-r--r--sysutils/u-boot-master/Makefile7
1 files changed, 1 insertions, 6 deletions
diff --git a/sysutils/u-boot-master/Makefile b/sysutils/u-boot-master/Makefile
index a0dce966861b..38fd6f081fbd 100644
--- a/sysutils/u-boot-master/Makefile
+++ b/sysutils/u-boot-master/Makefile
@@ -131,7 +131,6 @@ UBOOT_ARCH?= arm
.if ${UBOOT_ARCH} == arm
CROSS_COMPILE=arm-none-eabi-
ARCHFLAGS=ARCH=${UBOOT_ARCH}
-UBOOT_PLIST+= boot.scr
.elif ${UBOOT_ARCH} == aarch64
CROSS_COMPILE=aarch64-none-elf-
ARCHFLAGS=ARCH=arm
@@ -202,7 +201,6 @@ METADATA_BS=${UBOOT_METADATA_${FAMILY:tu}_RAW_BS}
post-patch:
@${REINPLACE_CMD} -e "s|make|${MAKE_CMD}|" ${WRKSRC}/scripts/kconfig/merge_config.sh
- ${CP} ${FILESDIR}/boot.cmd ${WRKSRC}/
.if defined(METADATA_METHOD)
@echo "METHOD=uboot-${METADATA_METHOD}" > ${WRKSRC}/metadata
@echo "FILES=\"${METADATA_FILES}\"" >> ${WRKSRC}/metadata
@@ -214,7 +212,7 @@ post-patch:
.endif
.if ${UBOOT_ARCH} == arm && !defined(CONFIG_FRAGMENT)
-# For armv6/v7 we want CONFIG_API
+# For armv6/v7 we want do disable secure mode and cache cleaning
# Use a KConfig fragment for that
FRAGMENT_NAME= FreeBSD_Fragment
CONFIG_FRAGMENT= ${FILESDIR}/${FRAGMENT_NAME}
@@ -230,9 +228,6 @@ do-configure:
.endif
post-build:
-.if ${UBOOT_ARCH} == arm
- mkimage -C none -A arm -T script -d ${FILESDIR}/boot.cmd ${WRKSRC}/boot.scr
-.endif
.if defined(UBOOT_EXTRA_TARGETS)
.for i in ${UBOOT_EXTRA_TARGETS}
(cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${MAKE_ENV} ${MAKE_CMD} ${MAKE_ARGS} ${i})