aboutsummaryrefslogtreecommitdiff
path: root/textproc/estraier/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/estraier/Makefile')
-rw-r--r--textproc/estraier/Makefile13
1 files changed, 7 insertions, 6 deletions
diff --git a/textproc/estraier/Makefile b/textproc/estraier/Makefile
index 518995fa1eec..6ae5798f132e 100644
--- a/textproc/estraier/Makefile
+++ b/textproc/estraier/Makefile
@@ -3,7 +3,7 @@
PORTNAME= estraier
PORTVERSION= 1.2.30
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= textproc
MASTER_SITES= http://fallabs.com/estraier/
@@ -24,7 +24,7 @@ CONFIGURE_ARGS= --with-sysqdbm \
--enable-dlfilter \
--enable-devel
CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -lpthread -L${LOCALBASE}/include
+LIBS+= -L${LOCALBASE}/include
CHASEN_LIB_DEPENDS= libchasen.so:${PORTSDIR}/japanese/chasen-base
CHASEN_CONFIGURE_ENABLE= chasen
@@ -40,14 +40,15 @@ CONFIGURE_ARGS+= --enable-mecab
.endif
post-patch:
+ @${REINPLACE_CMD} -e 's|-lc||' -e 's|-liconv|${ICONV_LIB}|' \
+ ${WRKSRC}/configure
@${REINPLACE_CMD} -e \
- 's|-lc ||g' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e \
- 's|-O2|@CFLAGS@|g ; \
+ 's|$$(RELCFLAGS)|@CFLAGS@| ; \
+ s|^LDFLAGS =|& @LDFLAGS@ | ; \
s|HOME|LOCALBASE|g ; \
s|:/usr/local/lib||g ; \
s|-I/usr/local/include||g ; \
- s|-L/usr/local/lib|-lpthread|g' ${WRKSRC}/Makefile.in
+ s|-L/usr/local/lib||g' ${WRKSRC}/Makefile.in
post-install:
.for file in estindex estmbtomh estserver estsiutil estxview