aboutsummaryrefslogtreecommitdiff
path: root/textproc/hs-polyparse/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/hs-polyparse/Makefile')
-rw-r--r--textproc/hs-polyparse/Makefile76
1 files changed, 0 insertions, 76 deletions
diff --git a/textproc/hs-polyparse/Makefile b/textproc/hs-polyparse/Makefile
deleted file mode 100644
index a6269383bff7..000000000000
--- a/textproc/hs-polyparse/Makefile
+++ /dev/null
@@ -1,76 +0,0 @@
-# New ports collection makefile for: hs-polyparse-ghc
-# Date created: January 23, 2009
-# Whom: Gabor Pali <pgj@FreeBSD.org>
-#
-# $FreeBSD$
-#
-
-PORTNAME= polyparse
-PORTVERSION= 1.4
-CATEGORIES= textproc haskell
-MASTER_SITES= http://hackage.haskell.org/packages/archive/${PORTNAME}/${PORTVERSION}/
-PKGNAMEPREFIX= hs-
-PKGNAMESUFFIX= -ghc
-
-MAINTAINER= haskell@FreeBSD.org
-COMMENT= Alternative parser combinator libraries for Haskell
-
-BUILD_DEPENDS= ghc>=6.10:${PORTSDIR}/lang/ghc
-RUN_DEPENDS= ghc>=6.10:${PORTSDIR}/lang/ghc
-
-GHC_VERSION= 6.10.4
-POLY_VERSION= ${PORTVERSION}
-
-GHC_CMD= ${LOCALBASE}/bin/ghc
-SETUP_CMD= ./setup
-
-DOCSDIR= ${PREFIX}/share/doc/${DISTNAME}
-POLY_LIBDIR_REL= lib/${DISTNAME}
-
-PLIST_SUB= GHC_VERSION=${GHC_VERSION} \
- POLY_LIBDIR_REL=${POLY_LIBDIR_REL} \
- POLY_VERSION=${POLY_VERSION}
-
-.if defined(NOPORTDOCS)
-PLIST_SUB+= NOPORTDOCS=""
-.else
-PLIST_SUB+= NOPORTDOCS="@comment "
-.endif
-
-.if !defined(NOPORTDOCS)
-
-PORT_HADDOCK!= (cd ${.CURDIR}/../../lang/ghc && ${MAKE} -V PORT_HADDOCK)
-.if !empty(PORT_HADDOCK:M?0)
-BUILD_DEPENDS+= haddock:${PORTSDIR}/devel/hs-haddock
-.endif
-BUILD_DEPENDS+= HsColour:${PORTSDIR}/print/hs-hscolour
-
-HSCOLOUR_VERSION= 1.15
-HSCOLOUR_DATADIR= ${PREFIX}/share/hscolour-${HSCOLOUR_VERSION}
-
-PORTDOCS= *
-.endif
-
-.SILENT:
-
-do-configure:
- cd ${WRKSRC} && ${GHC_CMD} --make Setup.hs -o setup -package Cabal \
- && ${SETUP_CMD} configure --haddock-options=-w --prefix=${PREFIX}
-
-do-build:
- cd ${WRKSRC} && ${SETUP_CMD} build \
- && ${SETUP_CMD} register --gen-script
-
-.if !defined(NOPORTDOCS)
- cd ${WRKSRC} && ${SETUP_CMD} haddock --hyperlink-source \
- --hscolour-css=${HSCOLOUR_DATADIR}/hscolour.css
-.endif
-
-do-install:
- cd ${WRKSRC} && ${SETUP_CMD} install \
- && ${INSTALL_SCRIPT} register.sh ${PREFIX}/${POLY_LIBDIR_REL}/register.sh
-
-post-install:
- ${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
-
-.include <bsd.port.mk>