aboutsummaryrefslogtreecommitdiff
path: root/textproc/hs-yaml/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/hs-yaml/Makefile')
-rw-r--r--textproc/hs-yaml/Makefile96
1 files changed, 53 insertions, 43 deletions
diff --git a/textproc/hs-yaml/Makefile b/textproc/hs-yaml/Makefile
index 159a36ed0c51..ec597b1152a8 100644
--- a/textproc/hs-yaml/Makefile
+++ b/textproc/hs-yaml/Makefile
@@ -1,9 +1,10 @@
PORTNAME= yaml
-PORTVERSION= 0.11.8.0
+PORTVERSION= 0.11.11.2
CATEGORIES= textproc haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Utilities for converting YAML and JSON documents back and forth
+WWW= https://github.com/snoyberg/yaml/
LICENSE= BSD3CLAUSE
@@ -11,55 +12,64 @@ USES= cabal
CONFLICTS_INSTALL= json2yaml # bin/json2yaml
-USE_CABAL= OneTuple-0.3.1_2 \
- QuickCheck-2.14.2 \
+USE_CABAL= OneTuple-0.4.1.1_1 \
+ QuickCheck-2.14.3 \
StateVar-1.2.2 \
- aeson-2.0.3.0 \
- ansi-terminal-0.11.3 \
- ansi-wl-pprint-0.6.9_3 \
- assoc-1.0.2_2 \
- attoparsec-0.14.4_1 \
- base-compat-0.12.1 \
- base-compat-batteries-0.12.1_2 \
- base-orphans-0.8.6 \
- bifunctors-5.5.12 \
+ aeson-2.2.1.0_1 \
+ ansi-terminal-1.0.2 \
+ ansi-terminal-types-0.11.5_1 \
+ assoc-1.1_1 \
+ attoparsec-0.14.4_5 \
+ base-orphans-0.9.1 \
+ bifunctors-5.6.1_2 \
+ bitvec-1.1.5.0 \
colour-2.3.6 \
- comonad-5.0.8_1 \
- conduit-1.3.4.2 \
+ comonad-5.0.8_2 \
+ conduit-1.3.5 \
contravariant-1.5.5 \
- data-fix-0.3.2_2 \
+ data-fix-0.3.2_5 \
distributive-0.6.2.1_1 \
- dlist-1.0 \
- hashable-1.4.0.2 \
- indexed-traversable-0.1.2_1 \
- indexed-traversable-instances-0.1.1 \
- integer-logarithms-1.0.3.1_2 \
- libyaml-0.1.2 \
+ dlist-1.0_1 \
+ foldable1-classes-compat-0.1_4 \
+ generically-0.1.1_2 \
+ hashable-1.4.3.0_1 \
+ indexed-traversable-0.1.3 \
+ indexed-traversable-instances-0.1.1.2_2 \
+ integer-conversion-0.1.0.1_1 \
+ integer-logarithms-1.0.3.1_5 \
+ libyaml-0.1.2_1 \
mono-traversable-1.0.15.3 \
- optparse-applicative-0.17.0.0 \
- primitive-0.7.3.0 \
- random-1.2.1.1 \
- resourcet-1.2.4.3_1 \
- scientific-0.3.7.0_2 \
- semialign-1.2.0.1_1 \
- semigroupoids-5.3.7 \
- split-0.2.3.4_2 \
- splitmix-0.1.0.4 \
- strict-0.4.0.1_4 \
- tagged-0.8.6.1_2 \
- text-short-0.1.5 \
- th-abstraction-0.4.3.0 \
- these-1.1.1.1_5 \
- time-compat-1.9.6.1_3 \
- transformers-compat-0.7.1_1 \
- unliftio-core-0.2.0.1_2 \
- unordered-containers-0.2.19.1 \
- uuid-types-1.0.5_2 \
- vector-0.12.3.1_1 \
- vector-algorithms-0.8.0.4_1 \
- witherable-0.4.2_2
+ network-uri-2.6.4.2_1 \
+ optparse-applicative-0.18.1.0 \
+ prettyprinter-1.7.1 \
+ prettyprinter-ansi-terminal-1.1.3 \
+ primitive-0.9.0.0 \
+ random-1.2.1.1_1 \
+ resourcet-1.3.0 \
+ scientific-0.3.7.0_7 \
+ semialign-1.3_1 \
+ semigroupoids-6.0.0.1_1 \
+ split-0.2.5 \
+ splitmix-0.1.0.5 \
+ strict-0.5_1 \
+ tagged-0.8.8 \
+ text-iso8601-0.1_1 \
+ text-short-0.1.5_3 \
+ th-abstraction-0.6.0.0_1 \
+ th-compat-0.1.4_4 \
+ these-1.2_1 \
+ time-compat-1.9.6.1_6 \
+ transformers-compat-0.7.2 \
+ unliftio-core-0.2.1.0_3 \
+ unordered-containers-0.2.20_1 \
+ uuid-types-1.0.5.1 \
+ vector-0.13.1.0 \
+ vector-algorithms-0.9.0.1_3 \
+ vector-stream-0.1.0.1 \
+ witherable-0.4.2_4
CABAL_EXECUTABLES= json2yaml yaml2json
CABAL_FLAGS= -no-exe
+CABAL_REVISION= 2
.include <bsd.port.mk>