aboutsummaryrefslogtreecommitdiff
path: root/textproc/kdiff3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/kdiff3/Makefile')
-rw-r--r--textproc/kdiff3/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/textproc/kdiff3/Makefile b/textproc/kdiff3/Makefile
index 8ab4ea6d3543..a723dc314096 100644
--- a/textproc/kdiff3/Makefile
+++ b/textproc/kdiff3/Makefile
@@ -1,25 +1,26 @@
PORTNAME= kdiff3
-DISTVERSION= 1.9.6
+DISTVERSION= 1.10.7
PORTREVISION= 1
CATEGORIES= textproc kde
MASTER_SITES= KDE/stable/${PORTNAME}
MAINTAINER= kde@FreeBSD.org
COMMENT= KDE graphical frontend for diff
+WWW= https://kdiff3.sourceforge.net/
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/include/boost/range/algorithm.hpp:devel/boost-libs
-USES= cmake compiler:c++11-lang kde:5 qt:5 tar:xz
-USE_KDE= auth bookmarks codecs completion config configwidgets \
- coreaddons crash i18n iconthemes jobwidgets kio \
- parts service solid sonnet textwidgets widgetsaddons windowsystem \
- xmlgui \
- doctools_build ecm_build
+USES= cmake compiler:c++11-lang kde:5 qt:5 tar:xz xorg
+USE_KDE= auth codecs completion config configwidgets coreaddons \
+ crash i18n jobwidgets kio parts service solid sonnet \
+ textwidgets widgetsaddons windowsystem xmlgui \
+ doctools:build ecm:build
USE_QT= concurrent core dbus gui network printsupport widgets xml \
- buildtools_build qmake_build
+ buildtools:build qmake:build
+USE_XORG= x11
OPTIONS_DEFINE= DOCS
DOCSDIR_REL= share/doc/HTML