aboutsummaryrefslogtreecommitdiff
path: root/textproc/luaexpat/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/luaexpat/Makefile')
-rw-r--r--textproc/luaexpat/Makefile14
1 files changed, 6 insertions, 8 deletions
diff --git a/textproc/luaexpat/Makefile b/textproc/luaexpat/Makefile
index f3febfbaefed..60d656237f77 100644
--- a/textproc/luaexpat/Makefile
+++ b/textproc/luaexpat/Makefile
@@ -4,24 +4,22 @@ PORTNAME= luaexpat
PORTVERSION= 1.3.0
PORTREVISION= 5
CATEGORIES= textproc
-MASTER_SITES= http://matthewwild.co.uk/projects/luaexpat/ \
- http://redundancy.redundancy.org/mirror/
+MASTER_SITES= https://matthewwild.co.uk/projects/luaexpat/
PKGNAMEPREFIX= ${LUA_PKGNAMEPREFIX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= sunpoet@FreeBSD.org
COMMENT= SAX XML parser based on Expat library
LICENSE= MIT
LIB_DEPENDS= libexpat.so:textproc/expat2
-USES= lua:module
-USES+= gmake
-ALL_TARGET= lib
+USES= gmake lua:module
+ALL_TARGET= lib
CFLAGS+= -fPIC
LDFLAGS+= -L${LOCALBASE}/lib
-MAKE_ARGS+= COMMON_CFLAGS="-Wall"
-MAKE_ENV= LUA_CDIR=${LUA_MODLIBDIR} LUA_LDIR=${LUA_MODSHAREDIR} LUA_INC="-I${LUA_INCDIR}" EXPAT_INC="-I${LOCALBASE}/include"
+MAKE_ARGS= COMMON_CFLAGS="-Wall"
+MAKE_ENV= EXPAT_INC=-I${LOCALBASE}/include LUA_CDIR=${LUA_MODLIBDIR} LUA_INC=-I${LUA_INCDIR} LUA_LDIR=${LUA_MODSHAREDIR}
.include <bsd.port.mk>