aboutsummaryrefslogtreecommitdiff
path: root/textproc/py-rich/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'textproc/py-rich/Makefile')
-rw-r--r--textproc/py-rich/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/textproc/py-rich/Makefile b/textproc/py-rich/Makefile
new file mode 100644
index 000000000000..a2cfe37fa845
--- /dev/null
+++ b/textproc/py-rich/Makefile
@@ -0,0 +1,24 @@
+# $FreeBSD$
+
+PORTNAME= rich
+PORTVERSION= 7.0.0
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= matthew@FreeBSD.org
+COMMENT= Rich text and beautiful formatting in the terminal
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}colorama>=0.4.0:devel/py-colorama@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}CommonMark>=0.9.0:textproc/py-CommonMark@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pygments>=2.6.0:textproc/py-pygments@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}typing-extensions>=3.7.4:devel/py-typing-extensions@${PY_FLAVOR}
+
+NO_ARCH= yes
+USES= python:3.6+
+USE_PYTHON= autoplist concurrent distutils
+
+.include <bsd.port.mk>