aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/kf5-sonnet/Makefile4
-rw-r--r--textproc/kf5-sonnet/files/patch-CMakeLists.txt13
2 files changed, 17 insertions, 0 deletions
diff --git a/textproc/kf5-sonnet/Makefile b/textproc/kf5-sonnet/Makefile
index 28fe9f58b0e2..2cc5f4ca1134 100644
--- a/textproc/kf5-sonnet/Makefile
+++ b/textproc/kf5-sonnet/Makefile
@@ -2,6 +2,7 @@
PORTNAME= sonnet
DISTVERSION= ${KDE_FRAMEWORKS_VERSION}
+PORTREVISION= 1
CATEGORIES= textproc kde kde-frameworks
MAINTAINER= kde@FreeBSD.org
@@ -15,4 +16,7 @@ USE_KDE= ecm
USE_QT= buildtools_build core gui linguisttools qmake_build \
testlib widgets
+# Disable examples -- they are not installed anyways.
+CMAKE_OFF= ENABLE_EXAMPLES
+
.include <bsd.port.mk>
diff --git a/textproc/kf5-sonnet/files/patch-CMakeLists.txt b/textproc/kf5-sonnet/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..acba95ad8547
--- /dev/null
+++ b/textproc/kf5-sonnet/files/patch-CMakeLists.txt
@@ -0,0 +1,13 @@
+Allow disabling building examples, as they are not installed anyways.
+
+--- CMakeLists.txt.orig 2019-06-23 11:56:17 UTC
++++ CMakeLists.txt
+@@ -53,7 +53,7 @@ if (NOT CMAKE_CROSSCOMPILING)
+ add_subdirectory(data)
+ endif()
+
+-if(TARGET Qt5::Widgets)
++if((TARGET Qt5::Widgets) AND (ENABLE_EXAMPLES))
+ add_subdirectory(examples)
+ endif()
+