aboutsummaryrefslogtreecommitdiff
path: root/textproc
diff options
context:
space:
mode:
Diffstat (limited to 'textproc')
-rw-r--r--textproc/xalan-c/Makefile25
-rw-r--r--textproc/xalan-c/distinfo5
-rw-r--r--textproc/xalan-c/files/patch-src_xalanc_CMakeLists.txt10
-rw-r--r--textproc/xalan-c/files/patch-src_xalanc_PlatformSupport_XalanLocator.hpp11
-rw-r--r--textproc/xalan-c/pkg-plist30
5 files changed, 44 insertions, 37 deletions
diff --git a/textproc/xalan-c/Makefile b/textproc/xalan-c/Makefile
index 4ad8c4b20eef..cbd44f052e88 100644
--- a/textproc/xalan-c/Makefile
+++ b/textproc/xalan-c/Makefile
@@ -2,27 +2,30 @@
# $FreeBSD$
PORTNAME= xalan-c
-PORTVERSION= 1.11
+PORTVERSION= 1.12
CATEGORIES= textproc
MASTER_SITES= APACHE/xalan/xalan-c/sources
-DISTNAME= xalan_c-${PORTVERSION}-src
+DISTNAME= xalan_c-${PORTVERSION}
-MAINTAINER= rleigh@codelibre.net
+MAINTAINER= rleigh@apache.org
COMMENT= XSLT processor from the Apache XML Project
LICENSE= APACHE20
LIB_DEPENDS= libxerces-c.so:textproc/xerces-c3
-GNU_CONFIGURE= yes
-USES= gmake libtool localbase pathfix
+USES= cmake compiler:c++11-lang
USE_LDCONFIG= yes
-MAKE_JOBS_UNSAFE= yes
-CONFIGURE_ENV= XALANCROOT=${WRKSRC} XALAN_LOCALE_SYSTEM=inmem \
- XALAN_LOCALE=en_US
-MAKE_ENV= ${CONFIGURE_ENV}
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-WRKSRC_SUBDIR= c
+CMAKE_ARGS= -Dmsgloader=inmemory -Dmessage-locale=en_US
+
+OPTIONS_DEFINE= ICU
+OPTIONS_DEFAULT= ICU
+OPTIONS_SUB= yes
+
+ICU_LIB_DEPENDS= libicuuc.so:devel/icu
+ICU_DESC= Use ICU for transcoding
+ICU_CMAKE_ON= -Dtranscoder=icu
+ICU_CMAKE_OFF= -Dtranscoder=default
.include <bsd.port.mk>
diff --git a/textproc/xalan-c/distinfo b/textproc/xalan-c/distinfo
index 22ad18475c5d..883d3402f554 100644
--- a/textproc/xalan-c/distinfo
+++ b/textproc/xalan-c/distinfo
@@ -1,2 +1,3 @@
-SHA256 (xalan_c-1.11-src.tar.gz) = 4f5e7f75733d72e30a2165f9fdb9371831cf6ff0d1997b1fb64cdd5dc2126a28
-SIZE (xalan_c-1.11-src.tar.gz) = 1689986
+TIMESTAMP = 1591528672
+SHA256 (xalan_c-1.12.tar.gz) = ee7d4b0b08c5676f5e586c7154d94a5b32b299ac3cbb946e24c4375a25552da7
+SIZE (xalan_c-1.12.tar.gz) = 1130924
diff --git a/textproc/xalan-c/files/patch-src_xalanc_CMakeLists.txt b/textproc/xalan-c/files/patch-src_xalanc_CMakeLists.txt
new file mode 100644
index 000000000000..f3a9012a728d
--- /dev/null
+++ b/textproc/xalan-c/files/patch-src_xalanc_CMakeLists.txt
@@ -0,0 +1,10 @@
+--- src/xalanc/CMakeLists.txt.orig 2020-06-07 09:17:25 UTC
++++ src/xalanc/CMakeLists.txt
+@@ -832,6 +832,7 @@ set(xalantransformer_sources
+ XalanTransformer/XercesDOMWrapperParsedSource.cpp)
+
+ set(xalantransformer_headers
++ XalanTransformer/XalanCAPI.h
+ XalanTransformer/XalanCompiledStylesheetDefault.hpp
+ XalanTransformer/XalanCompiledStylesheet.hpp
+ XalanTransformer/XalanDefaultDocumentBuilder.hpp
diff --git a/textproc/xalan-c/files/patch-src_xalanc_PlatformSupport_XalanLocator.hpp b/textproc/xalan-c/files/patch-src_xalanc_PlatformSupport_XalanLocator.hpp
deleted file mode 100644
index 61f679c10581..000000000000
--- a/textproc/xalan-c/files/patch-src_xalanc_PlatformSupport_XalanLocator.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/xalanc/PlatformSupport/XalanLocator.hpp.orig 2012-09-27 06:59:33 UTC
-+++ src/xalanc/PlatformSupport/XalanLocator.hpp
-@@ -91,7 +91,7 @@ public:
- const XalanDOMChar* theAlternateId = getEmptyPtr())
- {
- return theLocator == 0 ? theAlternateId : (theLocator->getSystemId() ?
-- theLocator->getPublicId() : theAlternateId);
-+ theLocator->getSystemId() : theAlternateId);
- }
-
- /**
diff --git a/textproc/xalan-c/pkg-plist b/textproc/xalan-c/pkg-plist
index 7c9ff86d2028..5fda2ba02034 100644
--- a/textproc/xalan-c/pkg-plist
+++ b/textproc/xalan-c/pkg-plist
@@ -12,17 +12,16 @@ include/xalanc/Harness/XalanDiagnosticMemoryManager.hpp
include/xalanc/Harness/XalanFileUtility.hpp
include/xalanc/Harness/XalanHarnessDefinitions.hpp
include/xalanc/Harness/XalanXMLFileReporter.hpp
-include/xalanc/Include/AIXDefinitions.hpp
-include/xalanc/Include/GCCDefinitions.hpp
-include/xalanc/Include/HPUXDefinitions.hpp
-include/xalanc/Include/IntelDefinitions.hpp
-include/xalanc/Include/OS390Definitions.hpp
-include/xalanc/Include/OS400Definitions.hpp
+%%ICU%%include/xalanc/ICUBridge/ICUBridge.hpp
+%%ICU%%include/xalanc/ICUBridge/ICUBridgeCleanup.hpp
+%%ICU%%include/xalanc/ICUBridge/ICUBridgeCollationCompareFunctor.hpp
+%%ICU%%include/xalanc/ICUBridge/ICUBridgeCollationCompareFunctorImpl.hpp
+%%ICU%%include/xalanc/ICUBridge/ICUBridgeDefinitions.hpp
+%%ICU%%include/xalanc/ICUBridge/ICUFormatNumberFunctor.hpp
+%%ICU%%include/xalanc/ICUBridge/ICUXalanNumberFormatFactory.hpp
+%%ICU%%include/xalanc/ICUBridge/ICUXalanNumberFormatProxy.hpp
include/xalanc/Include/PlatformDefinitions.hpp
include/xalanc/Include/STLHelper.hpp
-include/xalanc/Include/SolarisDefinitions.hpp
-include/xalanc/Include/TRU64Definitions.hpp
-include/xalanc/Include/VCPPDefinitions.hpp
include/xalanc/Include/XalanAutoPtr.hpp
include/xalanc/Include/XalanDeque.hpp
include/xalanc/Include/XalanList.hpp
@@ -444,9 +443,14 @@ include/xalanc/XercesParserLiaison/XercesWrapperNavigator.hpp
include/xalanc/XercesParserLiaison/XercesWrapperNavigatorAllocator.hpp
include/xalanc/XercesParserLiaison/XercesWrapperToXalanNodeMap.hpp
include/xalanc/XercesParserLiaison/XercesWrapperTypes.hpp
+lib/cmake/XalanC/XalanCConfig.cmake
+lib/cmake/XalanC/XalanCConfigInternal-%%CMAKE_BUILD_TYPE%%.cmake
+lib/cmake/XalanC/XalanCConfigInternal.cmake
+lib/cmake/XalanC/XalanCConfigVersion.cmake
lib/libxalan-c.so
-lib/libxalan-c.so.111
-lib/libxalan-c.so.111.0
+lib/libxalan-c.so.112
+lib/libxalan-c.so.112.0
lib/libxalanMsg.so
-lib/libxalanMsg.so.111
-lib/libxalanMsg.so.111.0
+lib/libxalanMsg.so.112
+lib/libxalanMsg.so.112.0
+libdata/pkgconfig/xalan-c.pc