aboutsummaryrefslogtreecommitdiff
path: root/www/civetweb/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/civetweb/Makefile')
-rw-r--r--www/civetweb/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/www/civetweb/Makefile b/www/civetweb/Makefile
index b011c9c4e494..e6baeea699c7 100644
--- a/www/civetweb/Makefile
+++ b/www/civetweb/Makefile
@@ -1,21 +1,24 @@
-# Created by: maintainer.freebsd@xpoundit.com
-
PORTNAME= civetweb
DISTVERSIONPREFIX= v
-DISTVERSION= 1.14
+DISTVERSION= 1.15
CATEGORIES= www
MAINTAINER= maintainer.freebsd@xpoundit.com
COMMENT= Embedded C/C++ web server
+WWW= https://github.com/civetweb/civetweb
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE.md
-USES= cmake
+USES= cmake cpe
+CPE_VENDOR= ${PORTNAME}_project
USE_GITHUB= yes
USE_LDCONFIG= yes
+CMAKE_ON= BUILD_SHARED_LIBS CIVETWEB_ENABLE_IPV6 CIVETWEB_ENABLE_SSL \
+ CIVETWEB_ENABLE_ZLIB
CMAKE_OFF= CIVETWEB_BUILD_TESTING
-CMAKE_ON= BUILD_SHARED_LIBS CIVETWEB_ENABLE_IPV6 CIVETWEB_ENABLE_SSL
+
+PLIST_SUB+= DISTVERSION=${DISTVERSION}
.include <bsd.port.mk>