aboutsummaryrefslogtreecommitdiff
path: root/www/cpr
diff options
context:
space:
mode:
Diffstat (limited to 'www/cpr')
-rw-r--r--www/cpr/Makefile10
-rw-r--r--www/cpr/distinfo6
-rw-r--r--www/cpr/files/patch-include-CMakeLists.txt11
-rw-r--r--www/cpr/pkg-descr2
-rw-r--r--www/cpr/pkg-plist5
5 files changed, 25 insertions, 9 deletions
diff --git a/www/cpr/Makefile b/www/cpr/Makefile
index 7ac39d37dfd3..976525ff8b8d 100644
--- a/www/cpr/Makefile
+++ b/www/cpr/Makefile
@@ -1,19 +1,21 @@
PORTNAME= cpr
-PORTVERSION= 1.9.0
+PORTVERSION= 1.10.4
CATEGORIES= www
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= C++ Requests: Curl for People
+WWW= https://github.com/libcpr/cpr
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libcurl.so:ftp/curl
-USES= cmake compiler:c++11-lang ssl
+USES= cmake compiler:c++17-lang ssl
-CMAKE_OFF= CPR_BUILD_TESTS CPR_BUILD_TESTS_SSL CPR_CURL_NOSIGNAL CPR_FORCE_DARWINSSL_BACKEND CPR_FORCE_WINSSL_BACKEND CPR_GENERATE_COVERAGE CPR_USE_SYSTEM_GTEST
-CMAKE_ON= BUILD_SHARED_LIBS CPR_ENABLE_SSL CPR_FORCE_OPENSSL_BACKEND CPR_FORCE_USE_SYSTEM_CURL
+CMAKE_OFF= CPR_BUILD_TESTS CPR_BUILD_TESTS_PROXY CPR_BUILD_TESTS_SSL CPR_CURL_NOSIGNAL CPR_DEBUG_SANITIZER_FLAG_ADDR CPR_DEBUG_SANITIZER_FLAG_ALL CPR_DEBUG_SANITIZER_FLAG_LEAK CPR_DEBUG_SANITIZER_FLAG_THREAD CPR_DEBUG_SANITIZER_FLAG_UB CPR_ENABLE_CPPCHECK CPR_ENABLE_CURL_HTTP_ONLY CPR_ENABLE_LINTING CPR_GENERATE_COVERAGE CPR_USE_BOOST_FILESYSTEM CPR_USE_SYSTEM_GTEST CURL_VERBOSE_LOGGING
+CMAKE_ON= BUILD_SHARED_LIBS BUILD_STATIC_LIBS CPR_ENABLE_SSL CPR_SKIP_CA_BUNDLE_SEARCH CPR_USE_SYSTEM_CURL
+PIE_UNSAFE= yes
PLIST_SUB= PORTVERSION=${PORTVERSION}
diff --git a/www/cpr/distinfo b/www/cpr/distinfo
index 33b6c01e14a3..b7fd495b50d5 100644
--- a/www/cpr/distinfo
+++ b/www/cpr/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1658176304
-SHA256 (libcpr-cpr-1.9.0_GH0.tar.gz) = 67023cde8979e8371f5ee7d6e586d6d0761af4a3a3a3be6270256353c9bf411f
-SIZE (libcpr-cpr-1.9.0_GH0.tar.gz) = 102426
+TIMESTAMP = 1685162048
+SHA256 (libcpr-cpr-1.10.4_GH0.tar.gz) = 88462d059cd3df22c4d39ae04483ed50dfd2c808b3effddb65ac3b9aa60b542d
+SIZE (libcpr-cpr-1.10.4_GH0.tar.gz) = 131684
diff --git a/www/cpr/files/patch-include-CMakeLists.txt b/www/cpr/files/patch-include-CMakeLists.txt
new file mode 100644
index 000000000000..6eef8b14961e
--- /dev/null
+++ b/www/cpr/files/patch-include-CMakeLists.txt
@@ -0,0 +1,11 @@
+--- include/CMakeLists.txt.orig 2023-01-26 16:47:20 UTC
++++ include/CMakeLists.txt
+@@ -60,7 +60,7 @@ if(CPR_USE_BOOST_FILESYSTEM)
+ endif()
+ endif()
+
+-if (((CMAKE_CXX_COMPILER_ID STREQUAL "GNU" AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS 9.1) OR CMAKE_CXX_COMPILER_ID STREQUAL "Clang") AND NOT CPR_USE_BOOST_FILESYSTEM)
++if (CMAKE_CXX_COMPILER_ID STREQUAL "GNU" AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS 9.1 AND NOT CPR_USE_BOOST_FILESYSTEM)
+ target_link_libraries(cpr PUBLIC stdc++fs)
+ endif()
+
diff --git a/www/cpr/pkg-descr b/www/cpr/pkg-descr
index ef2b18460594..cd43f47f93ae 100644
--- a/www/cpr/pkg-descr
+++ b/www/cpr/pkg-descr
@@ -5,5 +5,3 @@ Despite its name, libcurl's easy interface is anything but, and making mistakes
misusing it is a common source of error and frustration. Using the more
expressive language facilities of C++11, this library captures the essence of
making network calls into a few concise idioms.
-
-WWW: https://github.com/libcpr/cpr
diff --git a/www/cpr/pkg-plist b/www/cpr/pkg-plist
index bb1484caf303..795b182e0c3d 100644
--- a/www/cpr/pkg-plist
+++ b/www/cpr/pkg-plist
@@ -1,6 +1,7 @@
include/cpr/accept_encoding.h
include/cpr/api.h
include/cpr/async.h
+include/cpr/async_wrapper.h
include/cpr/auth.h
include/cpr/bearer.h
include/cpr/body.h
@@ -14,8 +15,10 @@ include/cpr/cprtypes.h
include/cpr/cprver.h
include/cpr/curl_container.h
include/cpr/curlholder.h
+include/cpr/curlmultiholder.h
include/cpr/error.h
include/cpr/file.h
+include/cpr/filesystem.h
include/cpr/http_version.h
include/cpr/interceptor.h
include/cpr/interface.h
@@ -24,6 +27,7 @@ include/cpr/local_port.h
include/cpr/local_port_range.h
include/cpr/low_speed.h
include/cpr/multipart.h
+include/cpr/multiperform.h
include/cpr/parameters.h
include/cpr/payload.h
include/cpr/proxies.h
@@ -31,6 +35,7 @@ include/cpr/proxyauth.h
include/cpr/range.h
include/cpr/redirect.h
include/cpr/reserve_size.h
+include/cpr/resolve.h
include/cpr/response.h
include/cpr/session.h
include/cpr/singleton.h