aboutsummaryrefslogtreecommitdiff
path: root/www/hs-DAV/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/hs-DAV/Makefile')
-rw-r--r--www/hs-DAV/Makefile182
1 files changed, 97 insertions, 85 deletions
diff --git a/www/hs-DAV/Makefile b/www/hs-DAV/Makefile
index a453417f7899..f39bd3ad1b86 100644
--- a/www/hs-DAV/Makefile
+++ b/www/hs-DAV/Makefile
@@ -1,126 +1,138 @@
PORTNAME= DAV
PORTVERSION= 1.3.4
-PORTREVISION= 4
+PORTREVISION= 6
CATEGORIES= www haskell
MAINTAINER= haskell@FreeBSD.org
COMMENT= Command line client for RFC 4918 WebDAV protocol
+WWW= http://floss.scru.org/hDAV
LICENSE= GPLv3
USES= cabal
-USE_CABAL= OneTuple-0.3.1_2 \
- QuickCheck-2.14.2 \
+USE_CABAL= OneTuple-0.4.1.1_1 \
+ QuickCheck-2.14.3 \
StateVar-1.2.2 \
- adjunctions-4.4.1 \
- aeson-2.0.3.0 \
- ansi-terminal-0.11.3 \
- ansi-wl-pprint-0.6.9_3 \
+ adjunctions-4.4.2_2 \
+ aeson-2.2.1.0_1 \
+ ansi-terminal-1.1 \
+ ansi-terminal-types-1.1 \
appar-0.1.8 \
asn1-encoding-0.9.6_2 \
asn1-parse-0.9.5 \
asn1-types-0.3.4 \
- assoc-1.0.2_2 \
- async-2.2.4_1 \
- attoparsec-0.14.4_1 \
- base-compat-0.12.1 \
- base-compat-batteries-0.12.1_2 \
- base-orphans-0.8.6 \
- base64-bytestring-1.2.1.0 \
- basement-0.0.14 \
- bifunctors-5.5.12 \
- blaze-builder-0.4.2.2_1 \
- blaze-html-0.9.1.2_2 \
- blaze-markup-0.8.2.8_2 \
+ assoc-1.1_1 \
+ async-2.2.5 \
+ attoparsec-0.14.4_5 \
+ base-orphans-0.9.1 \
+ base16-bytestring-1.0.2.0_1 \
+ base64-bytestring-1.2.1.0_1 \
+ basement-0.0.16 \
+ bifunctors-5.6.1_2 \
+ bitvec-1.1.5.0 \
+ blaze-builder-0.4.2.3 \
+ blaze-html-0.9.1.2_4 \
+ blaze-markup-0.8.3.0_1 \
byteorder-1.0.4 \
- cabal-doctest-1.0.9 \
+ cabal-doctest-1.0.9_3 \
call-stack-0.4.0 \
case-insensitive-1.2.1.0 \
- cereal-0.5.8.2 \
+ cborg-0.2.10.0 \
+ cereal-0.5.8.3 \
colour-2.3.6 \
- comonad-5.0.8_1 \
- conduit-1.3.4.2 \
- conduit-extra-1.3.5 \
- connection-0.3.1_1 \
+ comonad-5.0.8_2 \
+ conduit-1.3.5 \
+ conduit-extra-1.3.6 \
contravariant-1.5.5 \
- cookie-0.4.5 \
- cryptonite-0.30 \
+ cookie-0.4.6 \
+ crypton-0.34 \
+ crypton-connection-0.3.2 \
+ crypton-x509-1.7.6_1 \
+ crypton-x509-store-1.6.9 \
+ crypton-x509-system-1.6.7 \
+ crypton-x509-validation-1.6.12 \
data-default-0.7.1.1 \
data-default-class-0.1.2.0 \
data-default-instances-containers-0.0.1 \
data-default-instances-dlist-0.0.1 \
data-default-instances-old-locale-0.0.1 \
- data-fix-0.3.2_2 \
+ data-fix-0.3.2_5 \
distributive-0.6.2.1_1 \
- dlist-1.0 \
- file-embed-0.0.15.0 \
- free-5.1.8 \
- hashable-1.4.0.2 \
+ dlist-1.0_1 \
+ file-embed-0.0.16.0 \
+ free-5.2_3 \
+ generically-0.1.1_2 \
+ half-0.3.1_1 \
+ hashable-1.4.3.0_1 \
hourglass-0.2.12 \
- hsc2hs-0.68.8 \
- http-client-0.7.11_1 \
- http-client-tls-0.3.6.1 \
- http-types-0.12.3 \
- indexed-traversable-0.1.2_1 \
- indexed-traversable-instances-0.1.1 \
- integer-logarithms-1.0.3.1_2 \
- invariant-0.5.6 \
+ hsc2hs-0.68.10_1 \
+ http-client-0.7.16 \
+ http-client-tls-0.3.6.3 \
+ http-types-0.12.4 \
+ indexed-traversable-0.1.3 \
+ indexed-traversable-instances-0.1.1.2_2 \
+ integer-conversion-0.1.0.1_1 \
+ integer-logarithms-1.0.3.1_5 \
+ invariant-0.6.2_1 \
iproute-1.7.12 \
- kan-extensions-5.2.4 \
- lens-5.1_1 \
- memory-0.17.0 \
- mime-types-0.1.0.9 \
- mono-traversable-1.0.15.3 \
- network-3.1.2.7 \
- network-uri-2.6.4.1 \
+ kan-extensions-5.2.5_2 \
+ lens-5.2.3_2 \
+ memory-0.18.0 \
+ mime-types-0.1.2.0 \
+ mono-traversable-1.0.17.0 \
+ network-3.1.4.0_1 \
+ network-uri-2.6.4.2_1 \
old-locale-1.0.0.7_2 \
- optparse-applicative-0.17.0.0 \
- parallel-3.2.2.0_4 \
+ old-time-1.1.0.4 \
+ optparse-applicative-0.18.1.0 \
+ parallel-3.2.2.0_7 \
pem-0.2.4 \
- primitive-0.7.3.0 \
- profunctors-5.6.2_2 \
- random-1.2.1.1 \
- reflection-2.1.6_1 \
- resourcet-1.2.4.3_1 \
- scientific-0.3.7.0_2 \
- semialign-1.2.0.1_1 \
- semigroupoids-5.3.7 \
+ prettyprinter-1.7.1 \
+ prettyprinter-ansi-terminal-1.1.3 \
+ primitive-0.9.0.0 \
+ profunctors-5.6.2_3 \
+ random-1.2.1.2 \
+ reflection-2.1.7_1 \
+ resourcet-1.3.0 \
+ scientific-0.3.7.0_7 \
+ semialign-1.3_1 \
+ semigroupoids-6.0.0.1_1 \
semigroups-0.20 \
- shakespeare-2.0.27 \
+ serialise-0.2.6.1_1 \
+ shakespeare-2.1.0.1 \
socks-0.6.1 \
- split-0.2.3.4_2 \
- splitmix-0.1.0.4 \
- streaming-commons-0.2.2.4 \
- strict-0.4.0.1_4 \
- tagged-0.8.6.1_2 \
- text-short-0.1.5 \
- th-abstraction-0.4.3.0 \
- th-compat-0.1.3_1 \
- th-lift-0.8.2_1 \
- these-1.1.1.1_5 \
- time-compat-1.9.6.1_3 \
- tls-1.5.7 \
+ split-0.2.5 \
+ splitmix-0.1.0.5 \
+ streaming-commons-0.2.2.6_1 \
+ strict-0.5_1 \
+ tagged-0.8.8 \
+ text-iso8601-0.1_1 \
+ text-short-0.1.5_3 \
+ th-abstraction-0.6.0.0_1 \
+ th-compat-0.1.4_4 \
+ th-lift-0.8.4 \
+ these-1.2_1 \
+ time-compat-1.9.6.1_6 \
+ tls-2.0.1 \
transformers-base-0.4.6 \
- transformers-compat-0.7.1_1 \
- typed-process-0.2.8.0_1 \
- unliftio-core-0.2.0.1_2 \
- unordered-containers-0.2.19.1 \
+ transformers-compat-0.7.2 \
+ typed-process-0.2.11.1 \
+ unix-time-0.4.12 \
+ unliftio-core-0.2.1.0_3 \
+ unordered-containers-0.2.20_1 \
utf8-string-1.0.2 \
- uuid-types-1.0.5_2 \
- vector-0.12.3.1_1 \
- vector-algorithms-0.8.0.4_1 \
+ uuid-types-1.0.5.1 \
+ vector-0.13.1.0 \
+ vector-algorithms-0.9.0.1_3 \
+ vector-stream-0.1.0.1 \
void-0.7.3 \
- witherable-0.4.2_2 \
- x509-1.7.6 \
- x509-store-1.6.9 \
- x509-system-1.6.7 \
- x509-validation-1.6.12 \
- xml-conduit-1.9.1.1 \
+ witherable-0.4.2_4 \
+ xml-conduit-1.9.1.3 \
xml-hamlet-0.5.0.2 \
xml-types-0.3.8 \
- zlib-0.6.3.0
+ zlib-0.7.0.0
-EXECUTABLES= hdav
+CABAL_EXECUTABLES= hdav
.include <bsd.port.mk>