aboutsummaryrefslogtreecommitdiff
path: root/www/mohawk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/mohawk/Makefile')
-rw-r--r--www/mohawk/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/www/mohawk/Makefile b/www/mohawk/Makefile
new file mode 100644
index 000000000000..1dc0e973546c
--- /dev/null
+++ b/www/mohawk/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: mohawk
+# Date created: 2011-04-15
+# Whom: Baptiste Daroussin <bapt@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mohawk
+PORTVERSION= 0.8
+CATEGORIES= www ipv6
+MASTER_SITES= http://files.etoilebsd.net/mohawk/
+
+MAINTAINER= bapt@FreeBSD.org
+COMMENT= Simple and lightweight HTTP daemon
+
+LICENSE= BSD
+
+MAN1= mhtpasswd.1
+MAN8= mohawk.8
+
+PLIST_FILES+= bin/mhtpasswd \
+ sbin/mohawk \
+ etc/mohawk.conf.sample
+
+USE_RC_SUBR= mohawk
+
+.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 800000
+BROKEN= does not build on RELENG_7
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e '/.*rc.d\/mohawk.*/d' ${WRKSRC}/Makefile
+
+post-install:
+ @${INSTALL_DATA} ${WRKSRC}/mohawk.conf ${PREFIX}/etc/mohawk.conf.sample
+
+.include <bsd.port.post.mk>