aboutsummaryrefslogtreecommitdiff
path: root/www/mohawk/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/mohawk/Makefile')
-rw-r--r--www/mohawk/Makefile17
1 files changed, 8 insertions, 9 deletions
diff --git a/www/mohawk/Makefile b/www/mohawk/Makefile
index e4d6fa45d6a1..2b3d6816f9a0 100644
--- a/www/mohawk/Makefile
+++ b/www/mohawk/Makefile
@@ -1,8 +1,7 @@
PORTNAME= mohawk
-PORTVERSION= 2.0.21
+DISTVERSION= 2.0.21
CATEGORIES= www
-MASTER_SITES= http://fossil.bsdsx.fr/mohawk/tarball/
-DISTFILES= ${DISTNAME}.tar.gz?uuid=${PORTVERSION}
+MASTER_SITES= https://fossil.bsdsx.fr/mohawk/tarball/?r=${DISTVERSION}&name=/
MAINTAINER= dsx+mohawk@bsdsx.fr
COMMENT= Simple and lightweight HTTP daemon
@@ -11,19 +10,19 @@ LICENSE= BSD2CLAUSE
LIB_DEPENDS= libevent.so:devel/libevent
-PLIST_FILES+= bin/mhtpasswd \
+USES= localbase uidfix
+USE_RC_SUBR= mohawk
+
+CFLAGS+= -I${LOCALBASE}/include/event2/compat
+
+PLIST_FILES= bin/mhtpasswd \
man/man5/mohawk.conf.5.gz \
man/man8/mhtpasswd.8.gz \
man/man8/mohawk.8.gz \
sbin/mohawk \
etc/mohawk.conf.sample
-USES= uidfix
-
PORTEXAMPLES= *
-USE_RC_SUBR= mohawk
-
-CFLAGS+= -I${LOCALBASE}/include/event2/compat -I${LOCALBASE}/include
OPTIONS_DEFINE= EXAMPLES