aboutsummaryrefslogtreecommitdiff
path: root/www/pecl-http1/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/pecl-http1/Makefile')
-rw-r--r--www/pecl-http1/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/www/pecl-http1/Makefile b/www/pecl-http1/Makefile
new file mode 100644
index 000000000000..ab0c8ba64a60
--- /dev/null
+++ b/www/pecl-http1/Makefile
@@ -0,0 +1,31 @@
+# Created by: Wen Heping <wenheping@gmail.com>
+# $FreeBSD$
+
+PORTNAME= http
+PORTVERSION= 1.7.6
+CATEGORIES= www
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+PKGNAMESUFFIX= 1
+DISTNAME= pecl_http-${PORTVERSION}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Extended HTTP Support
+
+LICENSE= BSD2CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl
+
+USES= tar:tgz
+USE_PHP= yes
+USE_PHPEXT= yes
+PHP_MODNAME= http
+IGNORE_WITH_PHP= 56
+CONFLICTS= pecl-http-2*
+
+CONFIGURE_ARGS+= --with-http-curl-requests \
+ --with-http-zlib-compression \
+ --with-http-magic-mime
+
+.include <bsd.port.mk>