aboutsummaryrefslogtreecommitdiff
path: root/www/py-postorius/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-postorius/Makefile')
-rw-r--r--www/py-postorius/Makefile31
1 files changed, 16 insertions, 15 deletions
diff --git a/www/py-postorius/Makefile b/www/py-postorius/Makefile
index aa7b2b020404..bde9f092d473 100644
--- a/www/py-postorius/Makefile
+++ b/www/py-postorius/Makefile
@@ -1,29 +1,30 @@
PORTNAME= postorius
-PORTVERSION= 1.3.3
-PORTREVISION= 1
+PORTVERSION= 1.3.10
CATEGORIES= www
-MASTER_SITES= CHEESESHOP
+MASTER_SITES= PYPI
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-MAINTAINER= dvl@FreeBSD.org
-COMMENT= Django app provoding web user interface to access GNU Mailman
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Web user interface for GNU Mailman
+WWW= https://gitlab.com/mailman/postorius
LICENSE= GPLv3
LICENSE_FILE= ${WRKSRC}/COPYING
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django-mailman3>=1.3.3:mail/py-django-mailman3@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}django22>0:www/py-django22@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}mailmanclient>=3.3.1:mail/py-mailmanclient@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}django-gravatar2>1.0.6:www/py-django-gravatar2@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}readme-renderer>0:devel/py-readme-renderer@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}pytz>0:devel/py-pytz@${PY_FLAVOR}
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}django-mailman3>=1.3.10:mail/py-django-mailman3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}django32>=3.2<4.3:www/py-django32@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}mailmanclient>=3.3.3:mail/py-mailmanclient@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}readme-renderer>=0:devel/py-readme-renderer@${PY_FLAVOR}
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=0:www/py-beautifulsoup@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}django-debug-toolbar>=0:www/py-django-debug-toolbar@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}django-requests-debug-toolbar>=0:www/py-django-requests-debug-toolbar@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}isort>=0:devel/py-isort@${PY_FLAVOR}
-TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>0:www/py-beautifulsoup@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}isort>0:devel/py-isort@${PY_FLAVOR}
-
-USES= python:3.6+
+USES= cpe python
USE_PYTHON= autoplist concurrent distutils
NO_ARCH= yes
+CPE_VENDOR= postorius_project
+
.include <bsd.port.mk>