aboutsummaryrefslogtreecommitdiff
path: root/www/qutebrowser/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/qutebrowser/Makefile')
-rw-r--r--www/qutebrowser/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/www/qutebrowser/Makefile b/www/qutebrowser/Makefile
index ef0035fb655a..2f76ef3475ab 100644
--- a/www/qutebrowser/Makefile
+++ b/www/qutebrowser/Makefile
@@ -18,7 +18,7 @@ RUN_DEPENDS= \
${LOCALBASE}/lib/alsa-lib/libasound_module_pcm_oss.so:audio/alsa-plugins
USES= cpe desktop-file-utils python:3.6+ pyqt:5 qt:5
-USE_PYQT= dbus core opengl printsupport sql widgets qml
+USE_PYQT= pyqt5
USE_PYTHON= distutils autoplist noflavors
USE_QT= sql-sqlite3
@@ -27,19 +27,16 @@ EXTRACT_CMD= ${SETENV} LC_ALL=en_US.UTF-8 /usr/bin/bsdtar
NO_ARCH= yes
PLIST_FILES= share/applications/${PORTNAME}-${PYTHON_VER}.desktop
+OPTIONS_DEFINE= WEBENGINE
OPTIONS_DEFINE_amd64= ADBLOCK
-OPTIONS_DEFAULT= WEBKIT
OPTIONS_DEFAULT_amd64= WEBENGINE ADBLOCK
OPTIONS_DEFAULT_i386= WEBENGINE
-OPTIONS_MULTI= BACKEND
-OPTIONS_MULTI_BACKEND= WEBKIT WEBENGINE
ADBLOCK_DESC= Enable the newer adblocking support
WEBENGINE_DESC= WebEngine webpage renderer support
ADBLOCK_RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}adblock>=0.4.2:www/py-adblock@${PY_FLAVOR}
-WEBENGINE_USE= PYQT=webengine,webchannel
-WEBKIT_USE= PYQT=webkit,webkitwidgets
+WEBENGINE_USE= PYQT=webengine
.include <bsd.port.pre.mk>